Bug 978647 - `yum install openstack-dashboard` fails unless a python-django is also specified
`yum install openstack-dashboard` fails unless a python-django is also specified
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-django-horizon (Show other bugs)
19
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
: Reopened
: 1007140 1018360 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 22:37 EDT by Kevin
Modified: 2014-03-25 03:42 EDT (History)
14 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 03:42:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin 2013-06-26 22:37:57 EDT
Description of problem:

The openstack-dashboard package depends on python-django but yum cannot resolve which version to install. 

It appears to me that openstack-dashboard itself is satisfied by either python-django14 or the newer python-django package, and so the latest version will be chosen to resolve that dependency path. But it also pulls in python-django-horizon, which specifies python-django14, generating a conflicting set of dependencies to resolve.


Version-Release number of selected component (if applicable):

openstack-dashboard-2013.1.2-1.fc19.noarch


How reproducible:


Steps to Reproduce:

1. yum --enablerepo=updates-testing install openstack-dashboard


Actual results:

Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package openstack-dashboard.noarch 0:2013.1.2-1.fc19 will be installed
--> Processing Dependency: python-django-horizon >= 2013.1.2 for package: openstack-dashboard-2013.1.2-1.fc19.noarch
--> Processing Dependency: python-django-openstack-auth for package: openstack-dashboard-2013.1.2-1.fc19.noarch
--> Processing Dependency: python-django-compressor for package: openstack-dashboard-2013.1.2-1.fc19.noarch
--> Processing Dependency: python-django-appconf for package: openstack-dashboard-2013.1.2-1.fc19.noarch
--> Processing Dependency: mod_wsgi for package: openstack-dashboard-2013.1.2-1.fc19.noarch
--> Processing Dependency: httpd for package: openstack-dashboard-2013.1.2-1.fc19.noarch
--> Running transaction check
---> Package httpd.x86_64 0:2.4.4-6.fc19 will be installed
--> Processing Dependency: httpd-tools = 2.4.4-6.fc19 for package: httpd-2.4.4-6.fc19.x86_64
---> Package mod_wsgi.x86_64 0:3.4-8.fc19 will be installed
---> Package python-django-appconf.noarch 0:0.6-1.fc19 will be installed
--> Processing Dependency: Django for package: python-django-appconf-0.6-1.fc19.noarch
---> Package python-django-compressor.noarch 0:1.3-1.fc19 will be installed
--> Processing Dependency: python-versiontools for package: python-django-compressor-1.3-1.fc19.noarch
---> Package python-django-horizon.noarch 0:2013.1.2-1.fc19 will be installed
--> Processing Dependency: pytz for package: python-django-horizon-2013.1.2-1.fc19.noarch
--> Processing Dependency: python-django14 for package: python-django-horizon-2013.1.2-1.fc19.noarch
--> Processing Dependency: python-dateutil for package: python-django-horizon-2013.1.2-1.fc19.noarch
---> Package python-django-openstack-auth.noarch 0:1.0.11-1.fc19 will be installed
--> Running transaction check
---> Package httpd-tools.x86_64 0:2.4.4-6.fc19 will be installed
---> Package python-dateutil.noarch 0:1.5-6.fc19 will be installed
---> Package python-django.noarch 0:1.5.1-1.fc19 will be installed
---> Package python-django14.noarch 0:1.4.5-7.fc19 will be installed
---> Package python-versiontools.noarch 0:1.9.1-4.fc19 will be installed
---> Package pytz.noarch 0:2012d-4.fc19 will be installed
--> Processing Conflict: python-django14-1.4.5-7.fc19.noarch conflicts python-django >= 1.5
--> Processing Conflict: python-django14-1.4.5-7.fc19.noarch conflicts python-django >= 1.5
--> Finished Dependency Resolution
Error: python-django14 conflicts with python-django-1.5.1-1.fc19.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Expected results:

"Installation Complete"

Additional info:

`yum install openstack-dashboard python-django14` will install, although at this point I haven't tested whether the software will actually work with either version.
Comment 1 Matthias Runge 2013-06-28 16:56:26 EDT
This situation is unfortunate; still it is not solvable.
Dashboard does not work with python-django > 1.4, python-django-appconf does.  yum prefers packages with shorter names.
Both python-django*-packages provide python-django, so if python-django14 is installed, yum is also happy.
:-/
Comment 2 Fedora Update System 2013-07-03 04:00:15 EDT
python-django-horizon-2013.1.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-django-horizon-2013.1.2-2.fc19
Comment 3 Fedora Update System 2013-07-03 21:01:30 EDT
Package python-django-horizon-2013.1.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-django-horizon-2013.1.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12290/python-django-horizon-2013.1.2-2.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-18 01:49:45 EDT
python-django-horizon-2013.1.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Itamar Reis Peixoto 2013-08-21 18:54:08 EDT
its still happen for me.
Comment 6 Matthias Runge 2013-08-22 01:53:32 EDT
Itamar, do you already have python-django installed?
Comment 7 Itamar Reis Peixoto 2013-08-22 07:23:29 EDT
clean install
Comment 8 Tadej Janež 2013-08-28 10:18:00 EDT
I'm also hitting this with a clean F19 install from the Desktop live image.

I've used packstack to install OpenStack and it failed with this error.
Comment 9 Itamar Reis Peixoto 2013-08-28 11:49:06 EDT
if I install python-django14  first then it works.

yum -y install python-django14
Comment 11 Pádraig Brady 2013-09-12 06:48:36 EDT
*** Bug 1007140 has been marked as a duplicate of this bug. ***
Comment 12 Matthias Runge 2013-10-11 16:27:01 EDT
*** Bug 1018360 has been marked as a duplicate of this bug. ***
Comment 13 Alan Pevec 2013-11-28 06:25:38 EST
Copying from RDO post, worked fine with
 yum install openstack-dashboard python-django-horizon

Installing:
openstack-dashboard             noarch    2013.1.3-1.fc19     updates    975 k
python-django-horizon           noarch    2013.1.3-1.fc19     updates    378 k
Installing for dependencies:
mod_wsgi                        x86_64    3.4-8.fc19          fedora      75 k
pyparsing                       noarch    1.5.6-8.fc19        fedora      94 k
python-cinderclient             noarch    1.0.3-1.fc19        fedora      90 k
python-cliff                    noarch    1.3-2.fc19          fedora     113 k
python-cmd2                     noarch    0.6.4-7.fc19        updates     40 k
python-dateutil                 noarch    1.5-6.fc19          fedora      85 k
python-django-appconf           noarch    0.6-1.fc19          fedora      83 k
python-django-compressor        noarch    1.3-1.fc19          fedora     138 k
python-django-openstack-auth    noarch    1.0.11-1.fc19       updates     29 k
python-django14                 noarch    1.4.5-7.fc19        fedora     4.2 M
python-glanceclient             noarch    1:0.9.0-2.fc19      fedora      80 k
python-quantumclient            noarch    2:2.2.1-3.fc19      fedora     117 k
python-versiontools             noarch    1.9.1-4.fc19        fedora      99 k
python-warlock                  noarch    0.4.0-3.fc19        fedora      12 k
Comment 14 Steven Dake 2013-11-28 08:22:51 EST
Alan,

I think the issue is that packstack does the package installing typically, and it does not use this workaround.  It fails because it installs openstack-dashboard and not the correct python-django-horizon.  This bug represents more of a root-cause of why packstack was failing.
Comment 15 Matthias Runge 2014-03-25 03:42:56 EDT
based on a comment in bug 1066157, this is solved in dnf.

Note You need to log in before you can comment on or make changes to this bug.