Bug 978652 - Update instructions for ensuring images present console output to all required devices.
Update instructions for ensuring images present console output to all require...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: z3
: 4.0
Assigned To: Deepti Navale
ecs-bugs
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 23:02 EDT by Stephen Gordon
Modified: 2014-03-26 02:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 02:20:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-06-26 23:02:45 EDT
Under bug # 886338 an instruction was added to the documentation for building a custom disk image indicating users should add these parameters to the kernel arguments to ensure console output is visible via nova, the dashboard, and anything else that might need to access it:


serial=tty0 console=ttyS0,115200n8

As it turns out in RHEL at least serial isn't a valid argument (or at least is a noop) and does nothing, current thinking is this should actually read:

console=ttyS0,115200n8 console=tty0 

This needs to be confirmed though.
Comment 3 Matthew Miller 2013-06-27 09:59:26 EDT
Background: Graeme indicates that the info in the prior bug came from http://unix.stackexchange.com/questions/100/how-do-i-connect-a-serial-terminal-to-a-kvm-instance, and that in turn traces back to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507650#29, which I suspect is simply in error.
Comment 5 Deepti Navale 2014-01-16 22:42:36 EST
Hi Matthew, 

Can you please review this update using the link in comment 4?

Thanks,
Deepti
Comment 6 Deepti Navale 2014-03-20 21:21:32 EDT
Hi Graeme, 

Can you please review this update using the link in comment 4?

Thanks,
Deepti
Comment 7 Graeme Gillies 2014-03-20 21:25:19 EDT
This information looks good and correct to me

Regards,

Graeme
Comment 8 Deepti Navale 2014-03-20 21:33:44 EDT
Build: Red_Hat_Enterprise_Linux_OpenStack_Platform-Installation_and_Configuration_Guide-4-web-en-US-4-71.el6eng

Link: http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/4/html-single/Installation_and_Configuration_Guide/index.html#Building_a_Custom_Disk_Image

Note You need to log in before you can comment on or make changes to this bug.