Bug 978661 - 'Root Password Expiry' is not displayed on preferences page
'Root Password Expiry' is not displayed on preferences page
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.13
Unspecified Unspecified
medium Severity high (vote)
: 0.15.3
: ---
Assigned To: beaker-dev-list
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 23:44 EDT by wangjing
Modified: 2014-02-02 23:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-02 23:51:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wangjing 2013-06-26 23:44:51 EDT
Description of problem:
'Root Password Expiry' was not returned when update root password

Version-Release number of selected component (if applicable):
prod env Version - 0.13.1

How reproducible:
always

Steps to Reproduce:
1. 'hello'->Preferences.
2. update Root Password and click button 'change'.
3. check value in Root Password Expiry box.

Actual results:
no expiry time returned.

Expected results:
should return an expiry time.

Additional info:
it works on beaker-devel.
Comment 2 Nick Coghlan 2013-10-22 03:12:15 EDT
Adding this to the list for 0.15.2 - this is working in the integration environment (0.15.1), but not in either 0.14.1 deployment I have access too (including beaker.fedoraproject.org/bkr).

Once Fedora QA upgrades to 0.15.1, we should check it there and if it works, mark this as resolved.
Comment 3 Amit Saha 2014-01-15 01:26:00 EST
(In reply to Nick Coghlan from comment #2)
> Adding this to the list for 0.15.2 - this is working in the integration
> environment (0.15.1), but not in either 0.14.1 deployment I have access too
> (including beaker.fedoraproject.org/bkr).
> 
> Once Fedora QA upgrades to 0.15.1, we should check it there and if it works,
> mark this as resolved.

I can see this in production (0.14.4), but it works (no issue) in integration environment.
Comment 4 Nick Coghlan 2014-01-15 01:42:31 EST
Moving directly to MODIFIED, since we believe it has already been fixed, just needs to be confirmed by QE.
Comment 6 wangjing 2014-01-15 21:48:12 EST
verified on beaker-devel Version 0.15.2-->pass

Steps:
1. 'hello'->Preferences.
2. update Root Password and click button 'change'.
3. check value in Root Password Expiry box.

Actual results:
same as expected results.

Expected results:
should return a new expiry time.
Comment 7 Nick Coghlan 2014-02-02 23:51:46 EST
This change is included in the Beaker 0.15.3 maintenance release:

http://beaker-project.org/docs/whats-new/release-0.15.html#beaker-0-15-3

Note You need to log in before you can comment on or make changes to this bug.