Bug 978697 - [Docs] [Admin] Add VDSM hook for hotplug disk
[Docs] [Admin] Add VDSM hook for hotplug disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Tim Hildred
ecs-bugs
storage
: FutureFeature
: 976614 (view as bug list)
Depends On: 908656 976614
Blocks: 978698
  Show dependency treegraph
 
Reported: 2013-06-27 01:06 EDT by Andrew Burden
Modified: 2016-02-10 15:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 976614
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12479 None None None Never

  None (edit)
Comment 2 Tim Hildred 2013-08-06 01:14:12 EDT
Eli, do the new events around disk hot plug require an update to this paragraph:

"Most hook scripts are run as the vdsm user and inherit the environment of the VDSM process. The exceptions are hook scripts triggered by the before_vdsm_start and after_vdsm_stop events. Hook scripts triggered by these events run as the root user and do not inherit the environment of the VDSM process. "
Comment 3 Eli Mesika 2013-08-06 02:50:25 EDT
(In reply to Tim Hildred from comment #2)
> Eli, do the new events around disk hot plug require an update to this
> paragraph:
> 
> "Most hook scripts are run as the vdsm user and inherit the environment of
> the VDSM process. The exceptions are hook scripts triggered by the
> before_vdsm_start and after_vdsm_stop events. Hook scripts triggered by
> these events run as the root user and do not inherit the environment of the
> VDSM process. "

I don't think so
Comment 4 Tim Hildred 2013-09-02 21:15:12 EDT
Added to Supported VDSM Events:
- before_disk_hotplug
- after_disk_hotplug
- before_disk_hotunplug
- after_disk_hotunplug
- after_disk_hotplug_fail
- after_disk_hotunplug_fail
Comment 6 Tim Hildred 2013-09-02 21:43:14 EDT
*** Bug 976614 has been marked as a duplicate of this bug. ***
Comment 7 Tim Hildred 2013-10-03 22:18:20 EDT
Red_Hat_Enterprise_Virtualization-Administration_Guide-3.3-web-en-US-3.3-12.el6

Note You need to log in before you can comment on or make changes to this bug.