Bug 97874 - redhat bugzilla uses Javascript/GET when Form/POST should be used
Summary: redhat bugzilla uses Javascript/GET when Form/POST should be used
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
(Show other bugs)
Version: 2.18
Hardware: All Linux
medium
high vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-23 15:59 UTC by Toni Willberg
Modified: 2013-06-24 03:09 UTC (History)
0 users

Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 20:08:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toni Willberg 2003-06-23 15:59:43 UTC
F
This page:
 https://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi
uses Javascript for composing URL to next page on [Open Bugzilla Entry  Form]
-button.

This causes Apache to burn when the content of the form was quite long (not
massive long anyway):

 Request-URI Too Large
 The requested URL's length exceeds the capacity limit for this server.
 request failed: URI too long
 Apache/1.3.27 Server at bugzilla.redhat.com Port 443

Consider using "normal" <form> instead of Javascript.

This problem may cause people feel angry because they just lost they bugreport...

Comment 1 Toni Willberg 2003-06-23 16:00:36 UTC
"Apache to burb", I ment to say :)

Comment 2 David Lawrence 2006-04-08 18:08:07 UTC
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.

Comment 3 David Lawrence 2007-11-02 20:08:05 UTC
easy_enter_bug.cgi has been obsoleted in favor of a newer revamped guided bug
entry page. It is now using POST instead. Please open a new bug if the guided
entry page is still broken for you.


Note You need to log in before you can comment on or make changes to this bug.