Bug 978775 - is_node_member_clustat() causes services to be failed when a failed node rejoins the cluster
is_node_member_clustat() causes services to be failed when a failed node rejo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: David Vossel
Cluster QE
: ZStream
Depends On: 976443
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 02:45 EDT by Jan Kurik
Modified: 2014-04-07 16:43 EDT (History)
11 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-21.el6_4.3
Doc Type: Bug Fix
Doc Text:
Usage of lvm.sh with tags resulted in the stripping of cluster tags when the node rejoined the cluster. This was because the lvm.sh agent was unable to accurately detect the tag represented by a cluster node. Thus, the active logical volume on a cluster node failed when another node re-joined the cluster. This update properly detects whether tags represent a cluster node, the node-name, or, if fqdn is returned by the corosync-quorumtool -l output. When nodes re-join the cluster, tags are not stripped of LVM volume groups, and the volume group no longer fails on other nodes
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 13:06:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 404603 None None None Never

  None (edit)
Description Jan Kurik 2013-06-27 02:45:06 EDT
This bug has been copied from bug #976443 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 errata-xmlrpc 2013-07-01 13:06:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1007.html

Note You need to log in before you can comment on or make changes to this bug.