Bug 978849 - RFE: hooking a script into various stages of shutdown/rearly booot
RFE: hooking a script into various stages of shutdown/rearly booot
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
: FutureFeature, Reopened
Depends On:
Blocks: 959971
  Show dependency treegraph
 
Reported: 2013-06-27 04:25 EDT by Petr Sklenar
Modified: 2013-08-06 09:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 09:41:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-06-27 04:25:47 EDT
Description of problem:
Once we requested feature to see what happens during some stages.
There could be a way of hooking a script into various stages of shutdown/rearly booot


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
there is use case:
Try to execute some command before any other services start (previous rc.sysinit).
Try to execute some command after any other services start (previous rc.local). 


Actual results:


Expected results:
user would like to see progress during boot/shutdown

Additional info:
Comment 2 Harald Hoyer 2013-06-27 06:59:17 EDT
$ man bootup

you can create unit files with "After=" and "Before=" to sort yourself into the bootup sequence.

For /etc/rc.local there is /lib/systemd/system/rc-local.service, which executes /etc/rc.local, if it exists. It is ordered "After=network.target".
Comment 3 Harald Hoyer 2013-06-27 07:03:08 EDT
To see what happens, remove "quiet" from the kernel command line, or inspect the journal after booting.

# journalctl -b
Comment 6 Hans de Goede 2013-08-06 09:41:44 EDT
As explained already in comment #2 you can create unit files with "After=" and "Before=" to sort yourself into the bootup sequence.

We also still support rc.local, but only for compatibility reasons, the rc.local support is deliberately not advertised in the systemd documentation, since we discourage its use.

The systemd documentation in general does not document deprecated compatibility mechanisms to avoid promoting the use of them, ie it also does not document that the service and chkconfig commands can still be used.

Note You need to log in before you can comment on or make changes to this bug.