Bug 978955 - [RFE] Introduce --verbose option for systemctl start/stop to print transaction information
Summary: [RFE] Introduce --verbose option for systemctl start/stop to print transactio...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
Adela
URL:
Whiteboard:
: 1148571 (view as bug list)
Depends On:
Blocks: 959971 1113520 1203710 1205796 1295396 1025505 1133484 1297395
TreeView+ depends on / blocked
 
Reported: 2013-06-27 11:25 UTC by Petr Sklenar ⛄
Modified: 2018-12-17 19:11 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
When attempting to start, stop or restart a service or unit using the systemctl [start|stop|restart] NAME command, no message is displayed to inform the user whether the action has been successful.
Clone Of:
: 1133484 (view as bug list)
Environment:
Last Closed: 2016-10-18 11:29:34 UTC


Attachments (Terms of Use)

Description Petr Sklenar ⛄ 2013-06-27 11:25:20 UTC
Description of problem:
systemctl start NAME does not show success

Version-Release number of selected component (if applicable):
systemd-204-3.fc19.x86_64

How reproducible:
its rfe

Steps to Reproduce:
1. systemctl start NAME

Actual results:
users cannot see easily that service/unit starts successfully

Expected results:
[ OK ] can be at the output

Additional info:

Comment 7 Lukáš Nykrýn 2014-03-06 15:29:51 UTC
Just to clarify things here a little bit. If something goes wrong and the daemon's behavior is sane (for example don't use type=simple for daemon which requires configuration and can't run without it), we will print the error message. It would be nice to have some more verbose output, but that is something for 7.1.

Comment 9 Lukáš Nykrýn 2014-10-01 19:48:49 UTC
*** Bug 1148571 has been marked as a duplicate of this bug. ***

Comment 14 Michal Sekletar 2015-10-29 10:22:31 UTC
So far there was no progress upstream. But this bug is definitely on our radar for RHEL-7.3.

Comment 16 Andrew Sanders 2015-12-02 15:15:57 UTC
(In reply to Michal Sekletar from comment #14)
> So far there was no progress upstream. But this bug is definitely on our
> radar for RHEL-7.3.

Hi Michal,
  Now that RHEL7.2 has been released what's the status of this?  Will we get to it in RHEL7.2.z and/or RHEL7.3?

Comment 20 Lukáš Nykrýn 2016-06-02 08:50:04 UTC
Michal was working on that patch, but it seems to be pretty complicated. We can't make it to rhel-7.3.

From my point of view I am not even sure that this is something we want in to change in rhel7 at all.

Comment 21 Andrew Sanders 2016-06-24 22:13:50 UTC
(In reply to Lukáš Nykrýn from comment #20)
> Michal was working on that patch, but it seems to be pretty complicated. We
> can't make it to rhel-7.3.
> 
> From my point of view I am not even sure that this is something we want in
> to change in rhel7 at all.

Hi Lukas,
  I discussed this with the customer recently.  This is a feature that would be nice to have, but it's not a show-stopper by any means.  Is this something that will eventually make it into systemd, or is it best that we decline this bugzilla and close WONTFIX due to higher priority systemd bugzillas?  After all, this bugzilla has been open since 2013 with no firm commitment to being addressed soon.  :-)

Comment 22 Lukáš Nykrýn 2016-06-27 11:33:04 UTC
This is something we definitely want in systemd, but it will not happen any time soon. Maybe it would be better to not promise anything, close this as won't fix and then suprise our customers in the distant future.

Comment 23 Jan Synacek 2016-10-18 11:29:34 UTC
Not in scope for RHEL. If you insist on implementing such feature, please file an upstream request and reopen this bug with a link to it.

Comment 24 Paul Klapperich 2018-12-17 19:11:13 UTC
An upstream bug was already filed before this bug was closed. Here's a link to it:
https://github.com/systemd/systemd/issues/1287


Note You need to log in before you can comment on or make changes to this bug.