This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 978962 - tevent_loop_wait() never finishes
tevent_loop_wait() never finishes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtevent (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks: 994015
  Show dependency treegraph
 
Reported: 2013-06-27 07:50 EDT by Pavel Březina
Modified: 2014-07-23 05:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: libtevent-0.9.18-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994015 (view as bug list)
Environment:
Last Closed: 2013-11-21 00:42:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (1.10 KB, text/plain)
2013-06-27 07:50 EDT, Pavel Březina
no flags Details
patch (1.47 KB, patch)
2013-08-01 14:16 EDT, Andreas Schneider
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 10012 None None None Never

  None (edit)
Description Pavel Březina 2013-06-27 07:50:19 EDT
Created attachment 766074 [details]
reproducer

Description of problem:
If a signal handler is registered and unregistered later, tevent_loop_wait() never finishes.

Version-Release number of selected component (if applicable):
libtevent-0.9.17-1.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
Reproducer is attached.
1. gcc -ltalloc -ltevent tevent_loop.c
2. ./a.out

Actual results:
The program never gets out of tevent_loop_wait().
"We got through the loop! OK" is never printed.

Expected results:
The program gets through tevent_loop_wait().
"We got through the loop! OK" is printed.

Additional info:
This is because tevent internally registers its own signal handler "sig_pipe_handler". This handler is never removed, which causes program to stuck in tevent_loop_wait() even if there are no custom handlers registered.
Comment 2 Jakub Hrozek 2013-06-27 10:41:28 EDT
Pavel, can you bring this up on samba-technical and CC me, please?
Comment 4 Andreas Schneider 2013-07-11 09:02:11 EDT
I've created an upstream bug for the issue.
Comment 5 Andreas Schneider 2013-08-01 14:16:18 EDT
Created attachment 781696 [details]
patch

Here is the patch which has been pushed upstream.
Comment 7 Amith 2013-10-16 04:32:43 EDT
Verified the bug on libtevent Version: libtevent-0.9.18-3.el6.x86_64

Steps followed during verification:

1. Copied the reproducer "tevent_loop.c" onto the client system.
2. # gcc -ltalloc -ltevent tevent_loop.c

3. Execute the reproducer program:
 
[root@rhel-65 bkup]# ./a.out 
Registering signal handler...
Unregistering signal handler...
Entering tevent loop...
We got through the loop! OK

As expected, the program gets through tevent_loop_wait(), and prints "We got through the loop! OK".
Comment 9 errata-xmlrpc 2013-11-21 00:42:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1552.html

Note You need to log in before you can comment on or make changes to this bug.