Bug 978966 - sudoHost mismatch response is incorrect sometimes
sudoHost mismatch response is incorrect sometimes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On: 883106
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 07:56 EDT by Jakub Hrozek
Modified: 2013-11-21 17:20 EST (History)
7 users (show)

See Also:
Fixed In Version: sssd-1.9.2-100.el6
Doc Type: Bug Fix
Doc Text:
Cause: The sudo refresh handler used an incorrect callback, which might haev resulted in accessing wrong memory in some cases. Consequence: The wrong memory access caused sssd_sudo process crashes. Fix: The refresh handler uses the right callback now. Result: The sssd_sudo process no longer crashes.
Story Points: ---
Clone Of: 883106
Environment:
Last Closed: 2013-11-21 17:20:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1680 normal SHIPPED_LIVE sssd bug fix and enhancement update 2013-11-20 16:52:37 EST

  None (edit)
Comment 2 Jakub Hrozek 2013-06-27 10:46:02 EDT
Fixed upstream.
Comment 7 Nikolai Kondrashov 2013-09-05 10:00:58 EDT
Verified as fixed in the following packages:

libsss_sudo-1.9.2-123.el6.x86_64
sssd-1.9.2-123.el6.x86_64
sssd-debuginfo-1.9.2-123.el6.x86_64
libsss_autofs-1.9.2-123.el6.x86_64
sssd-client-1.9.2-123.el6.x86_64
libsss_idmap-1.9.2-123.el6.x86_64

Relevant sudo suite output:

:: [   PASS   ] :: stress_refresh_attr_host (Expected 0, got 0)
Comment 8 errata-xmlrpc 2013-11-21 17:20:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1680.html

Note You need to log in before you can comment on or make changes to this bug.