Bug 978971 - [abrt] mrpt-apps-1.0.0-2.fc19: handmade_aligned_free: Process /usr/bin/2d-slam-demo was killed by signal 6 (SIGABRT)
[abrt] mrpt-apps-1.0.0-2.fc19: handmade_aligned_free: Process /usr/bin/2d-sla...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mrpt (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
abrt_hash:ca32abedb2563271ccdf6a04197...
:
: 908217 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 08:07 EDT by Jan Sedlák
Modified: 2013-08-02 18:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: sympol-0.1.8-6.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 18:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.17 KB, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: core_backtrace (1.27 KB, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: dso_list (19.14 KB, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: environ (2.77 KB, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: maps (59.39 KB, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: open_fds (327 bytes, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details
File: proc_pid_status (792 bytes, text/plain)
2013-06-27 08:07 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2013-06-27 08:07:15 EDT
Description of problem:
Tried to run 2d-slam-demo.

Version-Release number of selected component:
mrpt-apps-1.0.0-2.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        2d-slam-demo
crash_function: handmade_aligned_free
executable:     /usr/bin/2d-slam-demo
kernel:         3.9.5-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000
var_log_messages: Jun 27 13:48:36 dhcp-2-112 abrt[2085]: Saved core dump of pid 2082 (/usr/bin/2d-slam-demo) to /var/tmp/abrt/ccpp-2013-06-27-13:48:35-2082 (13209600 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 handmade_aligned_free at /usr/include/eigen3/Eigen/src/Core/util/Memory.h:103
 #7 aligned_free at /usr/include/eigen3/Eigen/src/Core/util/Memory.h:233
 #8 conditional_aligned_free<true> at /usr/include/eigen3/Eigen/src/Core/util/Memory.h:299
 #9 conditional_aligned_delete_auto<double, true> at /usr/include/eigen3/Eigen/src/Core/util/Memory.h:425
 #10 ~DenseStorage at /usr/include/eigen3/Eigen/src/Core/DenseStorage.h:200
 #11 ~PlainObjectBase at /usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:72
 #12 ~Matrix at /usr/include/eigen3/Eigen/src/Core/Matrix.h:127
 #13 run at /usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:678
 #14 conservativeResize at /usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:323
 #15 internal_resize at /usr/src/debug/mrpt-1.0.0/libs/base/include/mrpt/math/math_frwds.h:90

Potential duplicate: bug 908217
Comment 1 Jan Sedlák 2013-06-27 08:07:19 EDT
Created attachment 766094 [details]
File: backtrace
Comment 2 Jan Sedlák 2013-06-27 08:07:21 EDT
Created attachment 766095 [details]
File: cgroup
Comment 3 Jan Sedlák 2013-06-27 08:07:24 EDT
Created attachment 766096 [details]
File: core_backtrace
Comment 4 Jan Sedlák 2013-06-27 08:07:27 EDT
Created attachment 766097 [details]
File: dso_list
Comment 5 Jan Sedlák 2013-06-27 08:07:30 EDT
Created attachment 766098 [details]
File: environ
Comment 6 Jan Sedlák 2013-06-27 08:07:33 EDT
Created attachment 766099 [details]
File: limits
Comment 7 Jan Sedlák 2013-06-27 08:07:37 EDT
Created attachment 766100 [details]
File: maps
Comment 8 Jan Sedlák 2013-06-27 08:07:39 EDT
Created attachment 766101 [details]
File: open_fds
Comment 9 Jan Sedlák 2013-06-27 08:07:43 EDT
Created attachment 766102 [details]
File: proc_pid_status
Comment 10 Rich Mattes 2013-06-28 23:23:28 EDT
It looks like this is really a problem in the Eigen library.  A similar backtrace was reported upstream at http://eigen.tuxfamily.org/bz/show_bug.cgi?id=554, I will try to apply the patch to eigen and rebuild mrpt this weekend.
Comment 11 Rich Mattes 2013-06-28 23:28:13 EDT
*** Bug 908217 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2013-07-21 15:28:41 EDT
sympol-0.1.8-6.fc19,polymake-2.12-7.fc19,mrpt-1.0.1-2.fc19,pcl-1.6.0-5.fc19,fawkes-0.5.0-8.fc19,eigen3-3.1.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sympol-0.1.8-6.fc19,polymake-2.12-7.fc19,mrpt-1.0.1-2.fc19,pcl-1.6.0-5.fc19,fawkes-0.5.0-8.fc19,eigen3-3.1.3-2.fc19
Comment 13 Fedora Update System 2013-07-22 21:14:10 EDT
Package sympol-0.1.8-6.fc19, polymake-2.12-7.fc19, mrpt-1.0.1-2.fc19, pcl-1.6.0-5.fc19, fawkes-0.5.0-8.fc19, eigen3-3.1.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sympol-0.1.8-6.fc19 polymake-2.12-7.fc19 mrpt-1.0.1-2.fc19 pcl-1.6.0-5.fc19 fawkes-0.5.0-8.fc19 eigen3-3.1.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13423/sympol-0.1.8-6.fc19,polymake-2.12-7.fc19,mrpt-1.0.1-2.fc19,pcl-1.6.0-5.fc19,fawkes-0.5.0-8.fc19,eigen3-3.1.3-2.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-08-02 18:08:17 EDT
sympol-0.1.8-6.fc19, polymake-2.12-7.fc19, mrpt-1.0.1-2.fc19, pcl-1.6.0-5.fc19, fawkes-0.5.0-8.fc19, eigen3-3.1.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.