This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 978979 - Regression in negative patterns in CEP
Regression in negative patterns in CEP
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Mario Fusco
Tomas David
: Regression
Depends On: 981270
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 08:25 EDT by Marek Winkler
Modified: 2014-08-06 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Winkler 2013-06-27 08:25:51 EDT
Description of problem:

Rules containing a "not" operator do not fire expected number of times. This is either a regression, or a consequence of switching to Phreak(?).

Please see tests in the attached pull request. These tests passed in 6.0.0.Beta3 but fail now.

Version-Release number of selected component (if applicable):

Drools 6.0.0-SNAPSHOT (very likely Drools 6.0.0.Beta4)

The tests passed in Beta3.

How reproducible:

Run NegativePatternsTest from the pull request which will be attached shortly.
Comment 1 Marek Winkler 2013-06-27 08:27:50 EDT
Pull request with reproducer: https://github.com/droolsjbpm/drools/pull/218
Comment 2 Marek Winkler 2013-06-27 08:36:56 EDT
The test counts the number of rule firings. The differences might be caused by timing issues, but the difference in the first case is too large to be caused by too slow test execution:

Failed tests:   testConstrainedAbsence(org.drools.compiler.integrationtests.NegativePatternsTest): expected:<301> but was:<1>  

testMultipleEntryPoints(org.drools.compiler.integrationtests.NegativePatternsTest): expected:<1> but was:<0>

  testMultipleEvents(org.drools.compiler.integrationtests.NegativePatternsTest): expected:<300> but was:<298>

  testSingleEvent(org.drools.compiler.integrationtests.NegativePatternsTest): expected:<1> but was:<0>
Comment 3 Edson Tirelli 2013-08-30 17:28:47 EDT
This depends on the fix for BZ-981270.
Comment 4 Mario Fusco 2013-09-03 14:39:08 EDT
Fixed as a side-effect of the fix for BZ-981270.
I added a test case demonstrating how it is working now here:

https://github.com/droolsjbpm/drools/commit/da3478100
Comment 8 Tomas David 2013-10-14 04:25:35 EDT
Verified on BRMS 6.0.0.ER4.

Note You need to log in before you can comment on or make changes to this bug.