Bug 97899 - customization guide needs more information
customization guide needs more information
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-23 16:04 EDT by S. Warwick
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-29 22:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description S. Warwick 2003-06-23 16:04:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
The appendix of this document provdes a method of recompiling the kernel from 
kernel-sources<xx>.rpm  The update site provides the kernel-sources for the 
i386 version, and the SRPMS for non-architecture specific sources.  

In performing a kernel update from the errata site (2.4.20-18-9) , I chose the 
file appropriate for my processor (athlon) to install, which worked just fine 
according to the documentation
rpm -ivh kernel-2.4.20-18.9.athlon.rpm

now, it has become necessary to install the exactly corresponding source tree 
due to needs of other installation programs ( in this case, NVIDIA driver ).  
Since only the SRPMS file exists,  There is no redhat official documented way 
to generate the corresponding source tree to my installed binary.  


As this is not a user-customized kernel, there should be a straightforward 
method to do this, and to end up with the source tree in the right place with 
the correct customizations.   

documentation should be provided on the process of 
downloading and using rpm, rpmbuild, whatever on the .src.rpm file to 

#1 generate the correct source tree corresponding to the kernel binaries 

#2 complete the generation of a kernel based upon an existing config file, and 
whatever else.   



Version-Release number of selected component (if applicable):
rhl-cg(EN)-9-HTML-RHI (2003-02-20T01:08)

How reproducible:
Always

Steps to Reproduce:
1. read manuals
2.
3.
    

Additional info:
Comment 1 Tammy Fox 2003-07-29 22:45:44 EDT
Note: Red Hat does not support recompiling the kernel for drivers not included
with the distribution.

Rebuilding the kernel from the SRPM package is one way to recompile the kernel.
The method described in the appendix is a different way to perform the same task.

Note You need to log in before you can comment on or make changes to this bug.