Bug 979018 - packstack should install mariadb instead of community-mysql on Fedora 19
packstack should install mariadb instead of community-mysql on Fedora 19
Status: CLOSED DUPLICATE of bug 981116
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 09:05 EDT by ryo fujita
Modified: 2013-07-10 12:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 12:57:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ryo fujita 2013-06-27 09:05:23 EDT
Description of problem:
Installing community-mysql-server results the 'mixed mysql'. And installing packstack fails with authentication error of mysql.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. yum -y install openstack-packstack
2. packstack --allinone
3.

Actual results:
community-mysql-server packages requires 'mysql-libs'. yum resolves the dependency with mariadb-libs not mysql-libs.

Expected results:


Additional info:

--- params.pp	2013-06-27 22:01:53.000000000 +0900
+++ params.pp.old	2013-06-27 22:01:38.000000000 +0900
@@ -32,8 +32,8 @@
       $basedir               = '/usr'
       $datadir               = '/var/lib/mysql'
       $service_name          = 'mysqld'
-      $client_package_name   = 'mariadb'
-      $server_package_name   = 'mariadb-server'
+      $client_package_name   = 'mysql'
+      $server_package_name   = 'mysql-server'
       $socket                = '/var/lib/mysql/mysql.sock'
       $pidfile               = '/var/run/mysqld/mysqld.pid'
       $config_file           = '/etc/my.cnf'
Comment 1 ryo fujita 2013-06-27 09:11:33 EDT
Sorry, correct patch is here.


--- params.pp.old	2013-06-27 22:01:38.000000000 +0900
+++ params.pp	2013-06-27 22:01:53.000000000 +0900
@@ -32,8 +32,8 @@
       $basedir               = '/usr'
       $datadir               = '/var/lib/mysql'
       $service_name          = 'mysqld'
-      $client_package_name   = 'mysql'
-      $server_package_name   = 'mysql-server'
+      $client_package_name   = 'mariadb'
+      $server_package_name   = 'mariadb-server'
       $socket                = '/var/lib/mysql/mysql.sock'
       $pidfile               = '/var/run/mysqld/mysqld.pid'
       $config_file           = '/etc/my.cnf'
Comment 2 Martin Magr 2013-07-10 12:57:51 EDT

*** This bug has been marked as a duplicate of bug 981116 ***

Note You need to log in before you can comment on or make changes to this bug.