Bug 979049 - tree twisties in evo's tree view stop working after clicking GtkStatusIcon
tree twisties in evo's tree view stop working after clicking GtkStatusIcon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk2 (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 09:40 EDT by Tomas Pelka
Modified: 2014-01-02 05:23 EST (History)
3 users (show)

See Also:
Fixed In Version: gtk2-2.20.1-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 00:29:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 581050 None None None Never

  None (edit)
Description Tomas Pelka 2013-06-27 09:40:18 EDT
Description of problem:
Small down arrows (I hope they are called "tree twisties") in tree view in Evolution stop working after som time of using Evolution.

Any suggestion how to debug it will be appreciated.

Version-Release number of selected component (if applicable):
evolution-2.32.3-9.el6

How reproducible:
100%

Steps to Reproduce:
1. start evolution and use it for some time 
2. try to wrap/unwrap some submenus in Evo's tree view on left
3.

Actual results:
cant wrap/unwrap submenu

Expected results:
should work

Additional info:
Comment 1 Matthew Barnes 2013-06-27 10:05:25 EDT
This is a GTK+ issue:
https://bugzilla.gnome.org/show_bug.cgi?id=581050

Something to do with the interaction between GtkStatusIcon and GtkTreeView.

Never got fully investigated by GTK+ maintainers.  We stopped using GtkStatusIcon about the time we ported to gtk3 and the problem went away on its own.
Comment 2 Milan Crha 2013-09-09 11:50:34 EDT
I tested the proposed upstream patch and indeed, it fixes the issue. I suggest to include the patch into the gtk2 update.
Comment 3 Benjamin Otte 2013-09-10 21:46:27 EDT
The patch has landed in GTK2 upstream, so it should be fine to include:

commit b32a9eb691920f21ad3b9127c833aaba15727c4b
Author: Michael Natterer <mitch@gimp.org>
Date:   Thu May 31 11:02:09 2012 +0200

    GtkTreeView: make tree expanding/collapsing more robust

    gtk_grab_remove() *after* we did the expanding/collapsing, otherwise
    grab_notify() might kick in and mess with our state. Fixes bug #675835.

 gtk/gtktreeview.c |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 4 Milan Crha 2013-09-11 02:12:59 EDT
Thanks Benjamin, I'm committing this to sources.
Comment 8 errata-xmlrpc 2013-11-21 00:29:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1544.html

Note You need to log in before you can comment on or make changes to this bug.