Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 979052 - Can't connect to xmpp server since upgrade from f18 to f19
Summary: Can't connect to xmpp server since upgrade from f18 to f19
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-27 13:44 UTC by Xavier Bachelot
Modified: 2013-07-05 01:57 UTC (History)
3 users (show)

Fixed In Version: pidgin-2.10.7-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-05 01:57:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Xavier Bachelot 2013-06-27 13:44:46 UTC
Description of problem:
I upgraded from f18 to f19 this morning. Since then I can't connect to an xmpp account. I get a 'Not Authorized" error. The same account on the same machine was working before the update. I configured the same account on another machine still running f18 and it can connect as expected.

Version-Release number of selected component (if applicable):
pidgin-2.10.7-2.fc18 works.
pidgin-2.10.7-2.fc19 doesn't.

How reproducible:
Always

Steps to Reproduce:
1. install pidgin-2.10.7-2.fc19
2. configure an xmpp account
3. enable account

Actual results:
"Not Authorized"

Expected results:
Connect and chat away...

Additional info:

Comment 1 Xavier Bachelot 2013-06-28 08:58:01 UTC
I reproduced the issue on yet another computer. the xmpp account was connecting properly before going from F18 to F19, but wasn't after.
However, I cannot reproduce this with another account on another xmpp server so this is not something specific to the xmpp protocol, but likely to the authentication on some xmpp servers.
Another point, I tried to reproduced with kopete, but it worked for both the version from F18 and F19.

Comment 2 Xavier Bachelot 2013-07-01 09:38:30 UTC
Fixed the issue by installing cyrus-sasl-scram.

Comment 3 Jan Synacek 2013-07-01 10:44:13 UTC
Hello Xavier,

are you sure that this worked in F18? There is no 'cyrus-sasl-scram' before F19.

I'll add the package to Requires to prevent this from happening again.

Comment 4 Xavier Bachelot 2013-07-01 11:52:30 UTC
Yes, I'm sure it was working in F18. I haven't checked the changelog and commits for cyrus-sasl, but there is a possibility the cyrus-sasl-scram sub-package is new with F19 and contains a subset of what was previously in the main cyrus-sasl package. As such, it would rather point at an issue with cyrus-sasl package, but adding the cyrus-sasl-scram or /usr/lib/sasl2/libscram.so.3 require to libpurple for F19+ is the correct fix/workaround for this issue.

Comment 5 Fedora Update System 2013-07-01 11:59:03 UTC
pidgin-2.10.7-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pidgin-2.10.7-3.fc19

Comment 7 Xavier Bachelot 2013-07-01 12:03:00 UTC
Thanks Jan. I will provide karma when the package hits updates-testing.

The cyrus-sasl commit that introduces the scram subpackage is this one :
http://pkgs.fedoraproject.org/cgit/cyrus-sasl.git/commit/?id=0f0cda2c52f765ce1219cf665e77ac793b43194c

Comment 8 Fedora Update System 2013-07-02 00:25:20 UTC
Package pidgin-2.10.7-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pidgin-2.10.7-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12095/pidgin-2.10.7-3.fc19
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-07-05 01:57:46 UTC
pidgin-2.10.7-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.