Bug 979099 - [abrt] kde-workspace-4.10.4-1.fc18: FixedVMPoolAllocator: Process /usr/bin/plasma-desktop was killed by signal 11 (SIGSEGV)
[abrt] kde-workspace-4.10.4-1.fc18: FixedVMPoolAllocator: Process /usr/bin/pl...
Status: CLOSED DUPLICATE of bug 877711
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:4f9f3c4e7fd3fe437d98061cee7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 11:17 EDT by René Romero Benavides
Modified: 2013-06-30 15:42 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 14:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (79.95 KB, text/plain)
2013-06-27 11:17 EDT, René Romero Benavides
no flags Details
File: cgroup (129 bytes, text/plain)
2013-06-27 11:17 EDT, René Romero Benavides
no flags Details
File: dso_list (18.78 KB, text/plain)
2013-06-27 11:17 EDT, René Romero Benavides
no flags Details
File: environ (1.83 KB, text/plain)
2013-06-27 11:17 EDT, René Romero Benavides
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-27 11:17 EDT, René Romero Benavides
no flags Details
File: maps (98.05 KB, text/plain)
2013-06-27 11:17 EDT, René Romero Benavides
no flags Details
File: open_fds (724 bytes, text/plain)
2013-06-27 11:18 EDT, René Romero Benavides
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-06-27 11:18 EDT, René Romero Benavides
no flags Details
File: var_log_messages (333 bytes, text/plain)
2013-06-27 11:18 EDT, René Romero Benavides
no flags Details
File: xsession_errors (2.17 KB, text/plain)
2013-06-27 11:18 EDT, René Romero Benavides
no flags Details

  None (edit)
Description René Romero Benavides 2013-06-27 11:17:27 EDT
Description of problem:
Instaled updates up to June 26 and the kvm stack, nothing else, the kde environment doesn't work unless in failsafe mode from then on.

Version-Release number of selected component:
kde-workspace-4.10.4-1.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/plasma-desktop --nocrashhandler
core_backtrace: 
crash_function: FixedVMPoolAllocator
executable:     /usr/bin/plasma-desktop
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 FixedVMPoolAllocator at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:310
 #1 QTJSC::ExecutablePool::systemAlloc at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:443
 #2 ExecutablePool at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocator.h:258
 #3 create at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocator.h:97
 #4 ExecutableAllocator at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocator.h:150
 #5 QTJSC::JSGlobalData::JSGlobalData at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
 #6 QTJSC::JSGlobalData::create at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
 #7 QScriptEnginePrivate::QScriptEnginePrivate at api/qscriptengine.cpp:979
 #8 QScriptEngine::QScriptEngine at api/qscriptengine.cpp:1964
 #9 QDeclarativeScriptEngine::QDeclarativeScriptEngine at qml/qdeclarativeengine.cpp:385
Comment 1 René Romero Benavides 2013-06-27 11:17:33 EDT
Created attachment 766209 [details]
File: backtrace
Comment 2 René Romero Benavides 2013-06-27 11:17:38 EDT
Created attachment 766210 [details]
File: cgroup
Comment 3 René Romero Benavides 2013-06-27 11:17:42 EDT
Created attachment 766211 [details]
File: dso_list
Comment 4 René Romero Benavides 2013-06-27 11:17:47 EDT
Created attachment 766212 [details]
File: environ
Comment 5 René Romero Benavides 2013-06-27 11:17:51 EDT
Created attachment 766213 [details]
File: limits
Comment 6 René Romero Benavides 2013-06-27 11:17:58 EDT
Created attachment 766214 [details]
File: maps
Comment 7 René Romero Benavides 2013-06-27 11:18:04 EDT
Created attachment 766215 [details]
File: open_fds
Comment 8 René Romero Benavides 2013-06-27 11:18:08 EDT
Created attachment 766216 [details]
File: proc_pid_status
Comment 9 René Romero Benavides 2013-06-27 11:18:12 EDT
Created attachment 766217 [details]
File: var_log_messages
Comment 10 René Romero Benavides 2013-06-27 11:18:16 EDT
Created attachment 766218 [details]
File: xsession_errors
Comment 11 Rex Dieter 2013-06-27 12:53:25 EDT
How much RAM/VM do you have?  It would appear the Qt JavaScript JIT is failing memory allocations.
Comment 12 René Romero Benavides 2013-06-27 13:11:09 EDT
free -m
             total       used       free     shared    buffers     cached
Mem:          3755       2980        775          0         96       1456
-/+ buffers/cache:       1427       2328
Swap:         3759          0       3759

vmstat
procs -----------memory---------- ---swap-- -----io---- -system-- ----cpu----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa
 0  0      0 737444  99324 1501148    0    0    78    20  145 1654  3  2 94  2
Comment 13 René Romero Benavides 2013-06-27 14:35:09 EDT
I just found the cause, I was tuning a Postgresql server and in the book I'm reading "PostgreSQL High Performace" is adviced to set vm.overcommit=0 for a PostgreSQL server. Reset it to its default value and things are working again. Thanks for your time
Comment 14 René Romero Benavides 2013-06-27 14:42:46 EDT
I'm sorry, the value that wm.overcommit was set to is 2, changed it to 0
Comment 15 Kevin Kofler 2013-06-30 15:42:28 EDT

*** This bug has been marked as a duplicate of bug 877711 ***

Note You need to log in before you can comment on or make changes to this bug.