This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979138 - [RFE] Specify driver specific metadata with a location
[RFE] Specify driver specific metadata with a location
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
4.0
Unspecified Unspecified
high Severity unspecified
: Upstream M3
: 4.0
Assigned To: Flavio Percoco
Yogev Rabl
https://blueprints.launchpad.net/glan...
: FutureFeature, TestOnly
Depends On: 988927 988928 1037283
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-06-27 14:08 EDT by John Bresnahan
Modified: 2016-04-26 15:57 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-glance-2013.2-3.el6ost
Doc Type: Enhancement
Doc Text:
In the OpenStack Image service, when a direct URL is returned to a client it is helpful to the client to have additional information about that URL. For example, with a file:// URL the client may need to know the NFS host that is exporting it, the mount point, and FS type used. This feature requests that each storage system has a means to return direct URL specific meta-data to the client when direct_url is enabled. Although all stores could support this feature already, only the filesystem one does. It does that by reading the metadata information from an external path, configurable through a configuration parameter `filesystem_store_metadata_file` in glance-api.conf
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:12:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bresnahan 2013-06-27 14:08:41 EDT
Allow for driver specific metadata to be associated with an image location.  This will allow nova compute to make better decisions when trying to interact with gluster.

https://blueprints.launchpad.net/glance/+spec/direct-url-meta-data
Comment 2 John Bresnahan 2013-06-27 14:13:15 EDT
an upstream patch has been submitted for review:

https://review.openstack.org/#/c/34492/
Comment 3 John Bresnahan 2013-07-22 22:26:58 EDT
The final patch has been accepted upstream: https://review.openstack.org/#/c/36884/. In order to test please do the following:

1) Install Glance and glance client.
2) create a file with valid JSON data such that it contains only unicode, lists, and dictionaries.
3) In glance-api.conf set:
   show_multiple_locations = True
   filesystem_store_metadata_file = <path to the file created in step #2>
4) Add an image to glance with glance client
5) Show the information about the image with glance client and api version 2:

glance --os-image-api-version 2 image-show <image id>

6) verify that the metadata is under the locations value in the output.
Comment 4 Stephen Gordon 2013-07-25 15:40:44 EDT
Hi John,

How do we expect this to be handled from a packaging perspective and where is that tracked? By that I mean will the initial file be created by the package install and be set up in the filesystem_store_metadata_file configuration key?

If this is required for a good gluster experience then we should make sure it works OOTB.

Thanks,

Steve
Comment 5 John Bresnahan 2013-07-25 15:48:32 EDT
(In reply to Stephen Gordon from comment #4)
> Hi John,
> 
> How do we expect this to be handled from a packaging perspective and where
> is that tracked? By that I mean will the initial file be created by the
> package install and be set up in the filesystem_store_metadata_file
> configuration key?
> 
> If this is required for a good gluster experience then we should make sure
> it works OOTB.
> 
> Thanks,
> 
> Steve

Steve,

Good questions.  This feature will be off by default.  Creating that file takes coordination with Nova (and further it requires a corresponding patch in nova that has not yet been accepted).  This is something that should be explicitly enabled by operators so by default no file is needed.  Thus this should not be an issue for packaging.

John
Comment 17 Bruce Reeler 2013-12-17 19:55:39 EST
Resetting needinfo for jbresnah because fpercoco supplied doc text.
Comment 18 Yogev Rabl 2013-12-19 08:47:57 EST
verified on:

python-glance-2013.2-5.el6ost.noarch
python-glanceclient-0.12.0-1.el6ost.noarch
openstack-glance-2013.2-5.el6ost.noarch
Comment 20 errata-xmlrpc 2013-12-19 19:12:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.