Bug 979145 - cherry-pick changes to enable ssl_to_gear option on endpoints
cherry-pick changes to enable ssl_to_gear option on endpoints
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On:
Blocks: 988576
  Show dependency treegraph
 
Reported: 2013-06-27 14:25 EDT by Luke Meyer
Modified: 2017-03-08 12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The SSL_ENDPOINT option is now available in the /etc/openshift/broker.conf file. In some environments, regulations may require encrypted connections between the client and the server. This new configuration setting controls whether direct SSL connections to gears are allowed, denied, or forced. By default, direct SSL connections to gears are allowed if a cartridge manifest supports it. Without this feature, the SSL connection would be terminated by the OpenShift Enterprise node web proxy. This feature allows the SSL connection to instead be terminated by the gear.
Story Points: ---
Clone Of:
: 988576 (view as bug list)
Environment:
Last Closed: 2013-08-05 13:18:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2013-06-27 14:25:40 EDT
Description of problem:
We need to track https://github.com/openshift/origin-server/pull/2769 into OSE.
origin-server git hash 4a1af2e7f0b8cf6dd38dcaf93db78939cdf06b19
Comment 2 chris alfonso 2013-07-10 10:29:05 EDT
Also pulled in 9ec0e331f48897af3ea9655348d07e7b09b49b29 as part of this functionality.
Comment 4 Brenton Leanhardt 2013-07-12 18:30:29 EDT
Fixed in:

rubygem-openshift-origin-common-1.8.12-1
rubygem-openshift-origin-controller-1.9.15-1.1
rubygem-openshift-origin-node-1.9.14-1.1
openshift-origin-broker-1.5.3-1
Comment 5 Gaoyun Pei 2013-07-15 06:01:12 EDT
Checked the code on puddle: 2013-07-12

The code alteration of git pull 4a1af2e7f0b8cf6dd38dcaf93db78939cdf06b19 & 9ec0e331f48897af3ea9655348d07e7b09b49b29 all merged into this puddle.
Comment 8 errata-xmlrpc 2013-08-05 13:18:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.