Bug 979146 - Clusters_from_scratch: some documentation tweaks
Clusters_from_scratch: some documentation tweaks
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pacemaker (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrew Beekhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 14:28 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2014-01-14 00:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 00:45:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-06-27 14:28:59 EDT
Description of problem:
Clusters_from_scratch is primarily directed at Fedora, so I'm putting this bug report here. The bug reporting address given in Clusters_from_scratch is obsolete, so I'm not sure where to go instead. Please redirect as necessary.

--
I was reading "Clusters from scratch", and I made some notes as I went along.
I think it is an excellent document, beautifully formatted, and quite informative. There's a request for bugreports in the document, so here it goes:

Version-Release number of selected component (if applicable):
http://clusterlabs.org/doc/en-US/Pacemaker/1.1-pcs/html/Clusters_from_Scratch/index.html

"Creating Active/Passive and Active/Active Clusters on Fedora"
Edition 5

(2. We Need Feedback!)
Following the link https://developerbugs.linuxfoundation.org/enter_bug.cgi?product=Pacemaker returns the following:
  Sorry, entering a bug into the product Pacemaker has been
  disabled.

  Please press Back and try again.

Oops :)

(Introduction, first sections)
Active/passive is not explained in the beginning at all. I have very little idea about clusters, and it was unclear for me what is the distinction until maybe 50% into the manual.

(2.1. os installation)
*Why* and *where*?
"In this section the installation of the host OS is described."?
or
"In this section the installation of a virtual machine
to be used a cluster node is described."? In general a little bit of overview would be nice, what is installed during the tutorial and how many machines will be required etc.

(2.1.1 networking)
service network start → systemctl start network
chkconfig network on → systemctl enable network

(2.2.4 short node names)
s/fully qualifier/fully qualified/

sed'ding /etc/sysconfig/network + source + hostname
can be replaced with a hostnamectl call.

Merge 2.4.1 and 2.4.2? (Both do yum install, and it's
easier to do it in one step.)

(2.4.1 install the cluster software)
Where? "Install the cluster software on the first node."?

(2.5.2. Notes on Multicast Address Assignment)
What is multicast being used for?

Also, how do nodes know about each other? I can presume that they use multicast advertisements or something, but the tutorial doesn't really say anything. 

(2.5.3 configuring corosync)
"started as a separate job/initscript" → "started as a separate service"
(job is an upstartism, probably confusing for fedora users, and it's not an initscript anymore).

(4.3 Verify Pacemaker Installation)
ps axf → systemctl status pacemaker

'grep -i error /var/log/messages' → 'journalctl -bp3'  (--this-boot --priority=3)


(6.3 preparation)
Formatting in second "screendump" is borked.

(7.3.1. Create A Partition for DRBD)
First grep: extra space before e

(8.2.2. Create and Populate an GFS2 Partition)
last "screendump" → formatting garbled at the end
Comment 1 Andrew Beekhof 2013-07-15 22:56:51 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #0)
> Description of problem:
> Clusters_from_scratch is primarily directed at Fedora, so I'm putting this
> bug report here. The bug reporting address given in Clusters_from_scratch is
> obsolete, so I'm not sure where to go instead. Please redirect as necessary.
> 
> --
> I was reading "Clusters from scratch", and I made some notes as I went along.
> I think it is an excellent document, beautifully formatted, and quite
> informative. There's a request for bugreports in the document, so here it
> goes:
> 
> Version-Release number of selected component (if applicable):
> http://clusterlabs.org/doc/en-US/Pacemaker/1.1-pcs/html/
> Clusters_from_Scratch/index.html
> 
> "Creating Active/Passive and Active/Active Clusters on Fedora"
> Edition 5
> 
> (2. We Need Feedback!)
> Following the link
> https://developerbugs.linuxfoundation.org/enter_bug.cgi?product=Pacemaker
> returns the following:
>   Sorry, entering a bug into the product Pacemaker has been
>   disabled.
> 
>   Please press Back and try again.
> 
> Oops :)

Fixed for existing html versions (not pdf or epub) and all future version.

> 
> (Introduction, first sections)
> Active/passive is not explained in the beginning at all. I have very little
> idea about clusters, and it was unclear for me what is the distinction until
> maybe 50% into the manual.

This is a Pacemaker primer, its not trying to cover everything about clustering in general.


Having said that, "1.4. Types of Pacemaker Clusters" says:

"Pacemaker makes no assumptions about your environment, this allows it to support practically any redundancy configuration including Active/Active, Active/Passive, N+1, N+M, N-to-1 and N-to-N."

Which contains a link to:
   http://en.wikipedia.org/wiki/High-availability_cluster#Node_configurations

Which defines the term and links to some suggested reading.

 

> (2.1. os installation)
> *Why* and *where*?

Where ever you like.  I'm using and documenting VMs because I dont have spare nodes floating around.

> "In this section the installation of the host OS is described."?
> or
> "In this section the installation of a virtual machine
> to be used a cluster node is described."? In general a little bit of
> overview would be nice, what is installed during the tutorial and how many
> machines will be required etc.
> 
> (2.1.1 networking)
> service network start → systemctl start network
> chkconfig network on → systemctl enable network

No, the former commands still work and are more widely applicable.

> 
> (2.2.4 short node names)
> s/fully qualifier/fully qualified/
> 
> sed'ding /etc/sysconfig/network + source + hostname
> can be replaced with a hostnamectl call.

on some systems

> Merge 2.4.1 and 2.4.2? (Both do yum install, and it's
> easier to do it in one step.)

No, there are two editions of this guide based around two different management tools.

> (2.4.1 install the cluster software)
> Where? "Install the cluster software on the first node."?

Ok, I'm made a couple of clarifications

> (2.5.2. Notes on Multicast Address Assignment)
> What is multicast being used for?

Corosync.
This information is left over from the time when:

"In the past, at this point in the tutorial an explanation of how to
configure and propagate corosync's /etc/corosync.conf file would be
necessary"


> 
> Also, how do nodes know about each other? I can presume that they use
> multicast advertisements or something, but the tutorial doesn't really say
> anything. 

"and then issue the pcs cluster setup command with a list of all the node names in the cluster."

> 
> (2.5.3 configuring corosync)
> "started as a separate job/initscript" → "started as a separate service"
> (job is an upstartism, probably confusing for fedora users, and it's not an
> initscript anymore).

sure

> (4.3 Verify Pacemaker Installation)
> ps axf → systemctl status pacemaker

god no!  one is accurate, the other presents results from some alternate reality

> 
> 'grep -i error /var/log/messages' → 'journalctl -bp3'  (--this-boot
> --priority=3)

also no.  even though the guide is written based on fedora, it is still helpful to remain relevant to people on other distros.

> 
> 
> (6.3 preparation)
> Formatting in second "screendump" is borked.

fixed
> 
> (7.3.1. Create A Partition for DRBD)
> First grep: extra space before e

fixed

> (8.2.2. Create and Populate an GFS2 Partition)
> last "screendump" → formatting garbled at the end

Note You need to log in before you can comment on or make changes to this bug.