Bug 979148 - port 2049 not being open for nfs
port 2049 not being open for nfs
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Shubhendu Tripathi
Dustin Tsang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 14:33 EDT by Dustin Tsang
Modified: 2015-07-13 00:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Previously, the IPtable rule was not present on the nodes making the NFS volumes unmountable. The fix opened a range of port numbers 38465-38468 and port 2049 to make the NFS volumes mountable.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 23:29:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16426 None None None Never

  None (edit)
Description Dustin Tsang 2013-06-27 14:33:41 EDT
Description of problem:

can not mount volume using nfs due to iptable rule not being present on the nodes.

Version-Release number of selected component (if applicable):
rhsc-bb4

node 
-----
RHS-2.120130619.n.0/2.1/RHS/x86_64/iso/RHS-2.1-20130619.n.0-RHS-x86_64-DVD1.iso 
http://download.devel.redhat.com/brewroot/packages/vdsm/4.10.2/22.4.el6rhs/noarch/vdsm-cli-4.10.2-22.4.el6rhs.noarch.rpm
http://download.devel.redhat.com/brewroot/packages/vdsm/4.10.2/22.4.el6rhs/noarch/vdsm-gluster-4.10.2-22.4.el6rhs.noarch.rpm
http://download.devel.redhat.com/brewroot/packages/vdsm/4.10.2/22.4.el6rhs/noarch/vdsm-reg-4.10.2-22.4.el6rhs.noarch.rpm
http://download.devel.redhat.com/brewroot/packages/vdsm/4.10.2/22.4.el6rhs/noarch/vdsm-xmlrpc-4.10.2-22.4.el6rhs.noarch.rpm
http://download.devel.redhat.com/brewroot/packages/vdsm/4.10.2/22.4.el6rhs/x86_64/vdsm-4.10.2-22.4.el6rhs.x86_64.rpm
http://download.devel.redhat.com/brewroot/packages/vdsm/4.10.2/22.4.el6rhs/x86_64/vdsm-python-4.10.2-22.4.el6rhs.x86_64.rpm


client (mounter)
--------------
nfs-utils-lib-1.1.5-6.el6.x86_64
nfs-utils-1.2.3-36.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. crate a 3.2 cluster
2. add two nodes to the cluster
3. create a distributed volume with nfs enabled
4. from a rhel client mount the volume

mount -t nfs rhsc-bb4-node-h:automation-volume-distribute-nfs-tests -o vers=3 /store/glusterMount/automation-volume-distribute-nfs-tests

Actual results:
connection times out

Expected results:
mounts successfully


Additional info:
workaround: adding port 2049 to be open in iptables allows the volume to be mounted
Comment 3 Sahina Bose 2013-07-02 02:19:23 EDT
As per Vijay,
We would need the following ports for nfs:

38465 - 38468 and 2049.

Need to change the SQL script to add this
Comment 4 Sahina Bose 2013-07-17 05:45:58 EDT
Fixed in bb6
Comment 5 Dustin Tsang 2013-07-22 15:32:34 EDT
Verified in bb6
Comment 6 Pavithra 2013-08-27 02:40:30 EDT
Kindly verify if the edited doc text is technically correct and sign off.
Comment 7 Shubhendu Tripathi 2013-08-27 02:49:15 EDT
Looks good
Comment 9 errata-xmlrpc 2013-09-15 23:29:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.