This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979151 - [RHSC] Adding a RHS 2.0+ node to a 3.2 cluster fails with no indication to the user as to why
[RHSC] Adding a RHS 2.0+ node to a 3.2 cluster fails with no indication to th...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kanagaraj
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 14:42 EDT by Matt Mahoney
Modified: 2016-04-18 06:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 11:19:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of 3.1 host (161.76 KB, image/png)
2013-06-28 01:53 EDT, Sahina Bose
no flags Details

  None (edit)
Description Matt Mahoney 2013-06-27 14:42:52 EDT
Description of problem:
Adding a RHS 2.0+ node into a 3.2 cluster with two RHS 2.1 nodes fails with no indication to the user as to the reason being due incomparability. The add just fails and goes into non-operational state, but the node should not have been allowed to be added from the start

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create 3.2 cluster
2. Added two RHS 2.1 nodes to cluster
3. Add RHS 2.0+ node

Actual results:


Expected results:
The RHS2.0+ node should be prevented from being added to a 3.2 cluster with RHS2.1 nodes.

Additional info:
Comment 1 Matt Mahoney 2013-06-27 14:45:03 EDT
Note: the same RHS2.0+ nodes add successfully into a 3.1 cluster, as would be expected.
Comment 3 Kanagaraj 2013-06-28 01:50:08 EDT
Following error message will be shown in the host-general tab
"Host's Compatibility Version doesn't match the Cluster's Compatibility Version."

Also there will be a event log "Host s3 is compatible with versions (2.0,3.0,3.1) and cannot join Cluster Default which is set to version 3.2."

Matt, please let me know if the above is not happening.
Comment 4 Sahina Bose 2013-06-28 01:53:03 EDT
Created attachment 766410 [details]
Screenshot of 3.1 host
Comment 5 Sahina Bose 2013-07-01 09:47:35 EDT
Matt, please let us know if you see details similar to one in attachment.
Comment 6 Matt Mahoney 2013-07-01 11:19:48 EDT
Retested. Validated that adding a RHS2.0+ host to a 3.2 Cluster is resulting in a compatibility error message as expected. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.