Bug 979154 - Fedora 19 RC2 kickstart with "repo --name=fedora" crashes
Summary: Fedora 19 RC2 kickstart with "repo --name=fedora" crashes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 19
Hardware: Unspecified Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-27 18:47 UTC by Edgar Hoch
Modified: 2013-08-02 20:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 20:24:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash file containing logs, kickstart etc. (924.21 KB, text/plain)
2013-06-27 18:47 UTC, Edgar Hoch
no flags Details

Description Edgar Hoch 2013-06-27 18:47:52 UTC
Created attachment 766279 [details]
anaconda crash file containing logs, kickstart etc.

Description of problem:

I installed Fedora 19 RC2 on a virtual machine using a kickstart file.
When I use only the expanded dvd (iso image mounted and copied) from an nfs partition, then the installation succeeds.

nfs --server=serverdvd.example.com --dir=/fs/tmp-local/boot_dir/Fedora/19/x86_64

But when I use also the predefined repos "fedora" (and "updates", but this does not make a difference), then the kickstart installation crashes.

repo --name=fedora


Version-Release number of selected component (if applicable):
Fedora 19 RC2

How reproducible:
Always.

Steps to Reproduce:
1. Create a kickstart file without "repo --name=fedora"
   and do a kickstart installation.
2.Create a kickstart file with "repo --name=fedora"
   and do a kickstart installation.

Actual results:
The first succeeds, the second fails.

Expected results:
Both succeed.

Additional info:
I append an attachment with the logs created by anaconda. This file also contains the error message. I changed the domain names and ip addresses for privacy.

I am not sure if the error results because the predefined repos are not ready before release of Fedora 19. But if this is not the reason then this may be an important bug.

Comment 1 Edgar Hoch 2013-06-27 20:05:18 UTC
I also tried using only the repo updates and not the repo fedora:

nfs --server=serverdvd.example.com --dir=/fs/tmp-local/boot_dir/Fedora/19/x86_64
#repo --name=fedora
repo --name=updates

This works fine.

But using repo fedora fails:

nfs --server=serverdvd.example.com --dir=/fs/tmp-local/boot_dir/Fedora/19/x86_64
repo --name=fedora
#repo --name=updates

crashes.

Comment 2 David Shea 2013-08-02 20:24:19 UTC
Hi, Edgar. The pre-release network repos are a moving target, and it looks like you hit them in a state where the package dependencies couldn't be resolved. Your kickstart should work the F19 release. If you still have problems, you can reopen this bug or file a new one.


Note You need to log in before you can comment on or make changes to this bug.