Bug 979155 - autofs-5.0.7-20 and later doesn't work with ldap
autofs-5.0.7-20 and later doesn't work with ldap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 14:49 EDT by Jimmy Dorff
Modified: 2013-07-07 20:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: autofs-5.0.7-23.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 20:51:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log, version 20, with failure on startup (6.72 KB, text/plain)
2013-06-27 22:18 EDT, Jimmy Dorff
no flags Details
Debug log, version 19, working correctly (7.48 KB, text/plain)
2013-06-27 22:18 EDT, Jimmy Dorff
no flags Details
Basic form of ldap automount used in this test (415 bytes, text/plain)
2013-06-27 22:31 EDT, Jimmy Dorff
no flags Details
Patch - fix add null check in parse_server_string() (1.30 KB, patch)
2013-06-28 01:55 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Jimmy Dorff 2013-06-27 14:49:26 EDT
Description of problem:
After update to autofs-5.0.7-22 from Fedora 19 testing, ldap autofs mounts do not work.


Version-Release number of selected component (if applicable):
autofs-5.0.7-22

How reproducible:
Everytime, multiple systems

Steps to Reproduce:
1. Have autofs configured for ldap maps via /etc/nsswitch.conf
2. Start autofs and note all the errors
3.

Actual results:
Jun 27 14:37:05 localhost systemd: Starting Automounts filesystems on demand...
Jun 27 14:37:05 localhost automount[1146]: parse_server_string: lookup(ldap): invalid LDAP map syntax dap.phy.duke.edu:ou=auto.home,dc=phy,dc=duke,dc=edu


Expected results:
older version autofs-5.0.7-14 works fine

Additional info:
Comment 1 Jimmy Dorff 2013-06-27 15:01:05 EDT
Don't know why is says "dap.phy.duke.edu". No idea where the "l" went to.
/etc/openldap/ldap.conf contains the correct values:
URI ldap://ldap.phy.duke.edu/
Comment 2 Jimmy Dorff 2013-06-27 17:20:33 EDT
More testing...
autofs-5.0.7-19.fc19.x86_64 works fine
autofs-5.0.7-20.fc19.x86_64 is broken
Comment 3 Ian Kent 2013-06-27 21:54:32 EDT
This would have to be the recent off-by-one change I did.

I tried a few different map entries and didn't see any problem.
What does your ldap map look like please?
A debug log could help too.
Comment 4 Jimmy Dorff 2013-06-27 22:18:03 EDT
Created attachment 766385 [details]
Debug log, version 20, with failure on startup
Comment 5 Jimmy Dorff 2013-06-27 22:18:50 EDT
Created attachment 766386 [details]
Debug log, version 19, working correctly
Comment 6 Jimmy Dorff 2013-06-27 22:21:03 EDT
I don't think it even gets to look at the ldap maps.. I think the problem is here:

Broken:
automount[2008]: lookup_nss_read_map: reading map ldap ldap:ldap.phy.duke.edu:ou=auto.home,dc=phy,dc=duke,dc=edu
automount[2008]: parse_server_string: lookup(ldap): Attempting to parse LDAP information from string "ldap:ldap.phy.duke.edu:ou=auto.home,dc=phy,dc=duke,dc=edu".
automount[2008]: parse_server_string: lookup(ldap): invalid LDAP map syntax dap.phy.duke.edu:ou=auto.home,dc=phy,dc=duke,dc=edu

Working:
automount[2176]: lookup_nss_read_map: reading map ldap ldap:ldap.phy.duke.edu:ou=auto.home,dc=phy,dc=duke,dc=edu
automount[2176]: parse_server_string: lookup(ldap): Attempting to parse LDAP information from string "ldap:ldap.phy.duke.edu:ou=auto.home,dc=phy,dc=duke,dc=edu".
automount[2176]: parse_server_string: lookup(ldap): server "ldap://ldap.phy.duke.edu/", base dn "ou=auto.home,dc=phy,dc=duke,dc=edu"
Comment 7 Jimmy Dorff 2013-06-27 22:31:03 EDT
Created attachment 766389 [details]
Basic form of ldap automount used in this test
Comment 8 Ian Kent 2013-06-28 01:55:03 EDT
Created attachment 766412 [details]
Patch - fix add null check in parse_server_string()

Yes, it was one of the Coverity changes.

A silly mistake, omitted braces around a conditional.

Odd though, I was sure I has tested that case since.
Comment 9 Fedora Update System 2013-06-28 01:58:42 EDT
autofs-5.0.7-23.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/autofs-5.0.7-23.fc19
Comment 10 Jimmy Dorff 2013-06-28 06:54:54 EDT
(In reply to Fedora Update System from comment #9)
> autofs-5.0.7-23.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/autofs-5.0.7-23.fc19

This is working correctly for me.
Comment 11 Fedora Update System 2013-06-29 11:22:40 EDT
Package autofs-5.0.7-23.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autofs-5.0.7-23.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11898/autofs-5.0.7-23.fc19
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-07-07 20:51:34 EDT
autofs-5.0.7-23.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.