Bug 979204 - horizon simple_ip_management not working
horizon simple_ip_management not working
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Julie Pichon
Ami Jeain
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 18:55 EDT by Graeme Gillies
Modified: 2015-06-04 17:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
OpenStack Networking (Neutron) is not compatible with 'simple IP management' in the Dashboard (Horizon): OpenStack Networking does not have a concept of a 'default' floating IP pool, additionally an OpenStack Networking floating IP can be associated with each instance's VIF, which would also require first checking whether an instance only has one VIF in order to enable simple association support. As a result, despite enabling 'simple_ip_management' in the Dashboard settings, the user still gets asked to select a floating IP pool when associating an IP. There is currently no workaround for OpenStack Networking. Simple IP management is only compatible with nova-network at this time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 06:47:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1196541 None None None Never

  None (edit)
Description Graeme Gillies 2013-06-27 18:55:38 EDT
Hi,

I have horizon installed and running, with one public network and one internal network

quantum net-list
+--------------------------------------+---------+-----------------------------------------------------+
| id                                   | name    | subnets                                             |
+--------------------------------------+---------+-----------------------------------------------------+
| 1702028d-d8f2-4bc1-aae2-41b62d2720bd | default | c87a9446-fb32-4508-bead-fa00709ee8bb 192.168.0.0/16 |
| c25e0cfc-228c-45d0-8809-926eabb7bbcd | public  | 3536fb53-6364-40cb-8669-cd9554a19865 10.10.152.0/21 |
+--------------------------------------+---------+-----------------------------------------------------+

quantum net-show c25e0cfc-228c-45d0-8809-926eabb7bbcd
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | c25e0cfc-228c-45d0-8809-926eabb7bbcd |
| name                      | public                               |
| provider:network_type     | vlan                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  | 1001                                 |
| router:external           | True                                 |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   | 3536fb53-6364-40cb-8669-cd9554a19865 |
| tenant_id                 | 986939150bdc449ebd53115256ad8f60     |
+---------------------------+--------------------------------------+

As you can see the router:external property is set

However, when I click the "associate floating ip" button in horizon, I get prompted to choose a floating ip from which floating ip pool (despite only having one), and then have to click the + button to add a floating IP if one isn't already available.

Looking in

/usr/lib/python2.6/site-packages/horizon/conf/default.py

I can see

    # Enable or disable simplified floating IP address management.
    'simple_ip_management': True

However it doesn't look like simple_ip_management is actually working/enabled at all. I checked my /etc/openstack-dashboard/local_settings and the setting isn't in there at all, so I assume it's using the default of true

Regards,

Graeme
Comment 2 Julie Pichon 2013-07-01 10:06:55 EDT
Thank you for the report. At the moment, simple_ip_management actually only works with nova-network.

In addition to the setting being set to True, the interface checks if the networking service in use supports it, which is currently not the case for Quantum due to not having a concept of default pool, and the fact that an instance make have multiple interface each requiring their own floating IP...

https://github.com/openstack/horizon/blob/stable/grizzly/openstack_dashboard/api/quantum.py#L197

It's not well documented. I filed LP 1196541 to fix the docs upstream.
Comment 3 Julie Pichon 2013-11-13 06:47:53 EST
The fix to the upstream docs is still on-going. I'm updating the Doc Text here to indicate this is a known issue. If we're not detailing the settings options in our docs though, perhaps this isn't necessary.

Note You need to log in before you can comment on or make changes to this bug.