Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 979324 - [RHSC] - Gluster Swift Services are not getting listed with vdsm build vdsm-4.10.2-22.5.el6rhs.x86_64
Summary: [RHSC] - Gluster Swift Services are not getting listed with vdsm build vdsm-4...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: ---
Assignee: Timothy Asir
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-28 08:45 UTC by RamaKasturi
Modified: 2013-09-23 22:25 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 22:25:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Attaching engine and vdsm logs. (15.14 MB, text/plain)
2013-06-28 08:49 UTC, RamaKasturi
no flags Details

Description RamaKasturi 2013-06-28 08:45:55 UTC
Description of problem:
Gluster siwft services are not getting listed with vdsm build 4.10.2.22.5

Version-Release number of selected component (if applicable):
vdsm-4.10.2-22.5.el6rhs.x86_64
rhsc-2.1.0-0.bb4.el6rhs.noarch
glusterfs-3.4.0.12rhs-1.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install vdsm version 4.10.2.22.5
2. Login to rhsc application
3. Click on GlusterSwift subtab under servers.

Actual results:
None of the services gets listed and there are some errors in vdsm.logs

Expected results:
All the glustersiwftservices should get listed.

Additional info:

Comment 1 RamaKasturi 2013-06-28 08:49:57 UTC
Created attachment 766466 [details]
Attaching engine and vdsm logs.

Comment 3 Timothy Asir 2013-07-01 12:07:38 UTC
It looks like it failed to give service list when any one of the following service is stopped.

glusterd,
memcached,
gluster-swift-proxy,
gluster-swift-container,
gluster-swift-object,
gluster-swift-account,
smb

I am suspecting "memcached" service is stopped. Can you restart the service memcached and check whether you are able to get the list of service list.

Quick Fix:
~~~~~~~~~~
restart all the following services:
glusterd,
memcached,
gluster-swift-proxy,
gluster-swift-container,
gluster-swift-object,
gluster-swift-account,
smb

Comment 4 RamaKasturi 2013-07-01 12:45:47 UTC
After doing the above quick fix, i was able to get the services listed, but all the services were listed after starting smb.

I am not able to understand what is the relation between smb and swift services. 
Could you please explain?

Comment 5 RamaKasturi 2013-07-08 06:58:34 UTC
Verified in vdsm-4.10.2-22.6.el6rhs.x86_64 and working fine.

Comment 6 Scott Haines 2013-09-23 22:25:51 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.