Bug 979343 - Decision table: Despite choosing operator "is contained in the a (comma separated) list" it's impossible to imput a comma in the columns if the type is numeric
Decision table: Despite choosing operator "is contained in the a (comma separ...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
5.x.x
Unspecified Unspecified
unspecified Severity medium
: DR6
: 6.0.0
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 05:27 EDT by Toshiya Kobayashi
Modified: 2014-08-06 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:15:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GUVNOR-1709 Major Resolved Decision table: Despite choosing operator "is contained in the a (comma separated) list" it's impossible to imput a comm... 2016-08-08 23:03 EDT

  None (edit)
Description Toshiya Kobayashi 2013-06-28 05:27:31 EDT
Description of problem:

Platform BZ for https://issues.jboss.org/browse/GUVNOR-1709


Steps to Reproduce:
1. Open 'Pricing loans' decision table in mortgages sample.
2. Edit condition column 'amount min'
3. Choose 'is contained in the (comma separated) list' as 'Operator:'
4. Press 'Apply changes'
5. Click the cell for 'amount min'
6. Input '1000,2000,3000'

Actual results: (BRMS 5.3.1)

Cannot input ',' in the cell

Expected results: (Drools 5.5.0)

Able to input the value and generated drl ("View source") will be "amount in ( 1000, 2000, 3000 )"
Comment 1 Toshiya Kobayashi 2013-06-28 05:29:26 EDT
BZ795815 is linked to GUVNOR-1709 but the BZ does not actually represent the JIRA.
Comment 2 Toshiya Kobayashi 2013-06-28 05:30:44 EDT
Move to 'MODIFIED' because it's already fixed in upstream.
Comment 3 Jiri Locker 2013-09-12 13:18:49 EDT
Fix verified in ER2.

Note You need to log in before you can comment on or make changes to this bug.