Bug 979382 - sudo packages requires vim-minimal
sudo packages requires vim-minimal
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
20
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 07:39 EDT by Martin M. S. Pedersen
Modified: 2017-03-29 12:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: sudo-1.8.12-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-23 18:24:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin M. S. Pedersen 2013-06-28 07:39:00 EDT
It should be possible to remove vim-minimal without losing sudo.
visudo can run with any CLI editor.

Suggestions:

Suggests:
1. Remove this requirement because visudo can use any CLI editor eg. 
EDITOR=nano visudo 
or
2. Make a abstract package vim which contains both vim-enhanced and vim-minimal and make the abstract package a requirement for sudo.


$ sudo yum remove vim-minimal
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
-> Package vim-minimal.x86_64 2:7.3.944-1.fc19 will be erased
--> Processing Dependency: vim-minimal for package: sudo-1.8.6p7-1.fc19.x86_64
--> Running transaction check
-> Package sudo.x86_64 0:1.8.6p7-1.fc19 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================
 Package                    Arch                  Version                          Repository                Size
==================================================================================================================
Removing:
 vim-minimal                x86_64                2:7.3.944-1.fc19                @fedora                 794 k
Removing for dependencies:
 sudo                       x86_64                1.8.6p7-1.fc19                  @anaconda               2.4 M
Comment 1 Karsten Hopp 2013-06-28 14:20:28 EDT
This needs to be fixed in sudo, not in vim as visudo is part of the sudo package
Comment 2 Jacob Keller 2014-09-17 14:24:48 EDT
Yes, I've had this problem on my machine. There is a work around by first removing sudo and vim-minimal, then installing vim-enhanced, and then sudo, which re-installs vim-minimal (even though we shouldn't need it, since visudo can use any editor!)

The other alternative is to install vim-enhanced with --force... Neither of these is a great solution. Instead, there should be a "vim" abstract package which both vim-minimal and vim-enhanced can supply, so that an install of vim-enhanced will simply remove vim-minimal with no issues.
Comment 3 Jacob Keller 2014-09-17 14:44:32 EDT
Note this is still a bug in sudo-1.8.8, and can easily be fixed by changing the Requires: vim-minimal to be "Requires: /usr/bin/vim"

It can also be changed to

Requires: vim

as long as both vim-minimal and vim-enhanced add virtual

Provides: vim

to their package files. This is a trivial fix which should not take long. I am willing to do this, but I am not sure how to submit a change to package spec files.
Comment 4 Jacob Keller 2014-09-17 15:58:29 EDT
Another possible solution is to have vim-enhanced provide the vim-minimal package which should resolve the issue.
Comment 5 Fedora Update System 2014-09-30 11:20:55 EDT
sudo-1.8.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sudo-1.8.11-1.fc20
Comment 6 Fedora Update System 2014-10-01 00:22:24 EDT
Package sudo-1.8.11-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sudo-1.8.11-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11928/sudo-1.8.11-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-11-03 09:27:17 EST
sudo-1.8.11p2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sudo-1.8.11p2-1.fc20
Comment 8 lnie 2014-11-04 03:01:37 EST
sudo-1.8.11p2-1.fc20 works
Comment 9 Fedora Update System 2015-02-18 05:20:21 EST
sudo-1.8.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sudo-1.8.12-1.fc20
Comment 10 Fedora Update System 2015-02-23 18:24:46 EST
sudo-1.8.12-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Haim Daniel 2015-11-03 08:01:20 EST
Problem still persists if fc22:

[hdaniel@hdaniel-x1 neutron (master)]$ rpm -qR sudo
/bin/chmod
/bin/sh
/etc/pam.d/system-auth
/usr/bin/vi
config(sudo) = 1.8.14p3-1.fc22
libaudit.so.1()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.11)(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.17)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.3)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.6)(64bit)
libc.so.6(GLIBC_2.8)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
liblber-2.4.so.2()(64bit)
libldap-2.4.so.2()(64bit)
libpam.so.0()(64bit)
libpam.so.0(LIBPAM_1.0)(64bit)
libselinux.so.1()(64bit)
libsudo_util.so.0()(64bit)
libutil.so.1()(64bit)
libutil.so.1(GLIBC_2.2.5)(64bit)
libz.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Comment 12 Reverend Homer 2017-03-29 12:37:50 EDT
Reopen this bug, please. Still reproducible with fedora 25:

λ sudo dnf remove vim-minimal
[sudo] password for ecko:
Dependencies resolved.
======================================================================================
 Package             Arch           Version                    Repository        Size
======================================================================================
Removing:
 sudo                x86_64         1.8.18p1-1.fc25            @updates         2.5 M
 vim-minimal         x86_64         2:8.0.502-1.fc25           @updates         1.0 M

Transaction Summary
======================================================================================
Remove  2 Packages

Installed size: 3.6 M
Is this ok [y/N]: n
Operation aborted.

Note You need to log in before you can comment on or make changes to this bug.