Bug 979387 - Striking lines through in LO-Draw draws that line at a too high position
Striking lines through in LO-Draw draws that line at a too high position
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: librelp (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Heinrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 07:54 EDT by Joachim Backes
Modified: 2016-09-20 00:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-28 06:34:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Layout of a crossed out line (1.59 KB, image/png)
2013-06-28 07:54 EDT, Joachim Backes
no flags Details
Overlined textin writer text boxes (2.08 KB, image/png)
2013-06-28 08:11 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2013-06-28 07:54:16 EDT
Created attachment 766537 [details]
Layout of a crossed out line

Description of problem:
Inserting Text into LO-Draw document and than striking through that text, the striking line has a too high position in the text line (it looks like overlined). The preview in the character dialog is correct!)

Version-Release number of selected component (if applicable):
libreoffice-core-4.1.0.1-3.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1.Open some LO draw document
2.Insert some text box and enter some text in this box
3.Menu: Format->character->strikethroug with a single line

Actual results:
The striking line is positioned too high (at the text's upper border

Expected results:
The striking line goes totally through the text

Additional info:
No such effect in the LO writer!
Comment 1 Joachim Backes 2013-06-28 08:11:21 EDT
Created attachment 766550 [details]
Overlined textin writer text boxes

In LO-Writer, there is another effect: overlining text in text boxes produces an overline too thick (dependent from the font size). See attachment.
Comment 2 Joachim Backes 2013-06-28 08:19:34 EDT
(In reply to Joachim Backes from comment #1)
> Created attachment 766550 [details]
> Overlined textin writer text boxes
> 
> In LO-Writer, there is another effect: overlining text in text boxes
> produces an overline too thick (dependent from the font size). See
> attachment.

This happens too in normal text (outside of a text box).
Comment 3 Joachim Backes 2013-07-01 08:20:22 EDT
After updating to LO-4.1.0.1-7 (from Koji), I'm not able to reproduce the described effect, seems to be fixed at least in this version :-)
Comment 4 Joachim Backes 2013-07-04 07:27:53 EDT
(In reply to Joachim Backes from comment #0)

> No such effect in the LO writer!

Later on I saw that this is not correct: Same effect in LO writer. The bigger the font size, the effect rises: fontsite=14: striking through is correct; font size  22: the string line is positioned too low.
Comment 5 Joachim Backes 2013-07-04 07:35:11 EDT
(In reply to Joachim Backes from comment #4)
> (In reply to Joachim Backes from comment #0)
> 
> > No such effect in the LO writer!
> 
> Later on I saw that this is not correct: Same effect in LO writer. The
> bigger the font size, the effect rises: fontsite=14: striking through is
> correct; font size  22: the string line is positioned too low.

This error appears too in LO-4.1.0.1-8.fc19.x86_64
Comment 6 Joachim Backes 2013-07-09 01:59:08 EDT
(In reply to Joachim Backes from comment #5)
> (In reply to Joachim Backes from comment #4)
> > (In reply to Joachim Backes from comment #0)
> > 
> > > No such effect in the LO writer!
> > 
> > Later on I saw that this is not correct: Same effect in LO writer. The
> > bigger the font size, the effect rises: fontsite=14: striking through is
> > correct; font size  22: the string line is positioned too low.
> 
> This error appears too in LO-4.1.0.1-8.fc19.x86_64

The error disappeared with libreoffice-4.1.0.2-1.fc19.x86_64 :-)

Note You need to log in before you can comment on or make changes to this bug.