This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979402 - Traceback ERROR com.redhat.rhn.manager.kickstart.cobbler.CobblerSystemCreateComman during provisioning wizard
Traceback ERROR com.redhat.rhn.manager.kickstart.cobbler.CobblerSystemCreateC...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Dimitar Yordanov
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-06-28 08:38 EDT by Pavel Studeník
Modified: 2013-10-01 17:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:59:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2013-06-28 08:38:44 EDT
Description of problem:
I created kickstart profile for provision real system - Virtualization Type is "None". And when I clicked on button "Schedule Kickstart and Finish" on page rhn/systems/details/kickstart/ScheduleWizard.do, I found error in log catelina.out. Problem is only traceback in log - I didn't find any other problem of functionality. 

If I set Virtualization Type to other value ( except "None"), then it's without traceback.


Version-Release number of selected component (if applicable):
spacewalk-java-1.9.83-45.el6sat.noarch


How reproducible:
always

Steps to Reproduce:
1. create kickstart profile with none Virtualization Type
2. provision system - click on button "Schedule Kickstart and Finish"
3. got error in catalina.out

Actual results:
traceback is in log

Expected results:
without traceback


Additional info:
>> tail /var/log/tomcat6/catalina.out

2013-06-29 01:07:46,191 [TP-Processor15] ERROR com.redhat.rhn.manager.kickstart.cobbler.CobblerSystemCreateCommand - This cobbler profile does not have a redhat_management_key set 
java.lang.NullPointerException
        at com.opensymphony.module.sitemesh.taglib.decorator.PropertyTag.doEndTag(PropertyTag.java:64)
        at org.apache.jsp.WEB_002dINF.pages.kickstart.wizard.schedule.fifth_jsp._jspx_meth_decorator_005fgetProperty_005f0(Unknown Source)
        at org.apache.jsp.WEB_002dINF.pages.kickstart.wizard.schedule.fifth_jsp._jspx_meth_c_005fif_005f2(Unknown Source)
        at org.apache.jsp.WEB_002dINF.pages.kickstart.wizard.schedule.fifth_jsp._jspService(Unknown Source)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
...
// cat
...
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
        at java.lang.Thread.run(Thread.java:736)
Comment 1 Stephen Herr 2013-07-15 17:07:09 EDT
Fixed in spacewalk master: e5372e275dd1e8f0ffded62f54e4e99f42073d43

By the way, a real (functional) side effect of this traceback was that if you tried to use the "delete system" or "add to / remove from ssm" links you would have gotten an internal service error (because the system id was not being included in the url).
Comment 4 Clifford Perry 2013-10-01 17:59:41 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.