Bug 979404 - adding beans.xml via addAsWebInfResource doesn't work with ShrinkWrap 1.1.2 and Arquillian 1.0.4.Final
adding beans.xml via addAsWebInfResource doesn't work with ShrinkWrap 1.1.2 a...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Arquillian (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity high
: CR2
: 2.3.0
Assigned To: Rodney Russ
thradec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 08:46 EDT by Ron Šmeral
Modified: 2016-10-31 21:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:27:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (3.53 KB, application/zip)
2013-06-28 08:46 EDT, Ron Šmeral
no flags Details

  None (edit)
Description Ron Šmeral 2013-06-28 08:46:30 EDT
Created attachment 766559 [details]
Reproducer

Description of problem:
When using addAsWebInfResource with ShrinkWrap 1.1.2 and Arquillian 1.0.4.Final, the added WEB-INF resources are 0 bytes in size.
With Arquillian 1.0.3.Final this works OK.

Version-Release number of selected component (if applicable):
WFK 2.3.0.CR1

How reproducible:
Run 'mvn clean test' in the reproducer

Actual results:
The ShrinkWrap-built archive fails to deploy because the beans.xml file is empty and thus doesn't declare the needed alternative bean.

Expected results:
The test passes.

Additional info:
It seems there is some other factor to this problem, because addWebInfResource seems to work in Seam examples but fails e.g. in cdi-add-interceptor quickstart.
Comment 3 Marek Schmidt 2013-07-01 06:38:30 EDT
A possible fix would be to downgrade arquillian to 1.0.3.Final
Comment 6 thradec 2013-07-02 13:38:06 EDT
verified on WFK-2.3.0.CR2

Note You need to log in before you can comment on or make changes to this bug.