Bug 979414 - systemd displays nothing during reboot and poweroff
systemd displays nothing during reboot and poweroff
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 09:21 EDT by Zdenek Wagner
Modified: 2013-09-12 23:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 23:07:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Wagner 2013-06-28 09:21:00 EDT
Description of problem:
Both Fedora 17 and 18 display nothing but the Fedora logo upon reboot and poweroff no matter whether it was invoked from the KDE menu or by "systemctl reboot" or "systemctl poweroff" from KDE Konsole or from a console opened by Ctrl-Shift-F2. No information about the current activity is shown. In Fedora 18 a few messages are displayed just immediately before reboot or poweroff is finished but there is no information why the action is waiting (or doing something else).

Version-Release number of selected component (if applicable):
systemd-201-2.fc18.7.x86_64 (Fedora 18)
systemd-44-24.fc17.x86_64 (Fedora 17)

How reproducible:
No output: always
Delayed poweroff/reboot: irregular

Steps to Reproduce:
1. Reboot or power off as explained above
2.
3.

Actual results:
Unreproducible delay (may be more than 20 minutes) with no messages.

Expected results:
Information what systemd is doing or why it is waiting, either as default or at least provide a button for displaying such messages

Additional info:
With systemd poweroff and reboot take typically 15 seconds, sometimes it requires loger time, sometimes the required time is very long. I rarely have enough patience to wait more than 5 minutes, thus I push RESET or power switch. Upon the next boot /var/log/messages contains no relevant message explaining what happened just before I pushed RESET or the power switch, either the kernel crashed silently or systemd was still waiting and not sending anything to /var/log/messages or the buffer was lost due to forced reset.
Comment 1 Lennart Poettering 2013-09-12 23:07:19 EDT
Plymouth is the graphical boot splash which hides what is currently going on. 

Press ESC to get the more verbose output or remove "quiet" and "rhgb" from the kernel command line.

Note You need to log in before you can comment on or make changes to this bug.