Bug 979436 - [One-Off] BRMS has performance decrease after applied Roll Up patch BRMS_5.3.1_2_2013 (BZ-953308)
[One-Off] BRMS has performance decrease after applied Roll Up patch BRMS_5.3....
Status: CLOSED NOTABUG
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRE (Expert, Fusion) (Show other bugs)
BRMS 5.3.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mario Fusco
Lukáš Petrovický
:
Depends On: 976824
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 10:01 EDT by Alessandro Lazarotti
Modified: 2013-07-04 11:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 11:06:24 EDT
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Lazarotti 2013-06-28 10:01:55 EDT
After applied the Roll Up patch BRMS_5.3.1_2_2013 the rule engine has decreased in 6% its performance.

This regression is related to BZs: Bug 976824 and Bug 969467
Comment 1 Mario Fusco 2013-07-01 06:25:37 EDT
The problem reported here https://bugzilla.redhat.com/show_bug.cgi?id=969467 was caused by a wrong synchronization pattern that, in order to be fixed, required a change in the policy in how locks are acquired, together with the introduction of a new type of lock. This caused a performance degradation that I partially addressed by tweaking the internal data structures of the before mentioned new lock. Unfortunately I don't see a way to avoid both the deadlock reported in that ticket and the remaining 6% of performance loss reported here. 

Of course performance is an important feature and we are striving to keep the rule engine as fast as possible, but at the same time we cannot trade correctness for performance.
Comment 3 Alessandro Lazarotti 2013-07-04 11:06:24 EDT
As commented by engineer and after some reviews, a minor loss of performance, which can vary between 3% to 6%, is expected due additional locks needed to fix Bug 969467. This value is not noticeable for most use cases. 

I am closing this ticket as "not a bug" status.

Note You need to log in before you can comment on or make changes to this bug.