Bug 979442 - Attempts to install multiple versions of the same cartridge should be detected early and be disallowed
Attempts to install multiple versions of the same cartridge should be detecte...
Status: CLOSED DUPLICATE of bug 980760
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Reopened
Depends On:
Blocks: 980739
  Show dependency treegraph
 
Reported: 2013-06-28 10:22 EDT by Hiro Asari
Modified: 2015-05-14 20:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 17:36:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiro Asari 2013-06-28 10:22:24 EDT
Description of problem:
If a single embeddable cartridge provides multiple versions of the same software (e.g., postgresql-8.4 and postgresql-9.2) it is conceivable to add a second cartridge to the same application.

In the case of postgresql, the second one will fail, because the first one has already created a database with the name $OPENSHIFT_APP_NAME. However, not all cartridges may fail similarly, and could lead to unexpected results.
Comment 1 Jhon Honce 2013-06-28 11:05:30 EDT
It was determined earlier that supporting two versions of any cartridge within one gear or application would not be supported.
Comment 2 Hiro Asari 2013-06-28 12:31:33 EDT
This is not about supporting it. I agree that it is not a good idea.

Rather, we would want to detect that such a maneuver is attempted, and inform the user with a meaningful message, rather than rely on each cartridge to fail somehow.
Comment 3 Hiro Asari 2013-07-03 09:56:54 EDT
This should be more gracefully disallowed. Currently it is possible to get around this loose restriction with CLI (see https://bugzilla.redhat.com/show_bug.cgi?id=980760 and https://bugzilla.redhat.com/show_bug.cgi?id=980739).

Reopening and sending this to the broker team for further consideration.
Comment 4 Hiro Asari 2013-07-05 11:35:42 EDT
Since v2 cartridge dropped the version suffix fromt the directory name, multiple versions will install to the same directory, causing strange problems.
Comment 5 Hiro Asari 2013-07-09 17:36:27 EDT
Closing this as duplicate.

*** This bug has been marked as a duplicate of bug 981528 ***
Comment 6 Hiro Asari 2013-07-09 17:52:43 EDT

*** This bug has been marked as a duplicate of bug 980760 ***

Note You need to log in before you can comment on or make changes to this bug.