Bug 979450 - The gedit plugin should work with python2
The gedit plugin should work with python2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: devhelp (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 11:12 EDT by Matěj Cepl
Modified: 2016-03-14 09:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: devhelp-3.8.2-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:47:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (2.28 KB, patch)
2013-06-28 11:12 EDT, Matěj Cepl
no flags Details | Diff
rebased patch (554 bytes, patch)
2013-10-08 12:44 EDT, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Matěj Cepl 2013-06-28 11:12:03 EDT
Created attachment 766599 [details]
suggested patch

Description of problem:
devhelp gedit plugin still requires python3, although that is not present in RHEL-7

Version-Release number of selected component (if applicable):
devhelp-3.8.2-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.activate devhelp plugin in gedit
2.
3.

Actual results:
(gedit:15228): libpeas-WARNING **: Could not find loader 'python3' for plugin 'devhelp'


Expected results:
activated plugin

Additional info:

The following changes since commit 5ba40f4b7c10cbd8c48a210a3a4b4f7d42f89388:

  Merge remote branch 'fedora/f19' into rhel-7.0 (2013-05-27 09:13:31 -0400)

are available in the git repository at:


  http://luther.ceplovi.cz/git/devhelp-pkg.git mybuild

for you to fetch changes up to bc2137549b51b4b1afd5c5184de20def2e406197:

  Make the gedit-plugin work with python2 (2013-06-28 16:35:36 +0200)

----------------------------------------------------------------
Matěj Cepl (1):
      Make the gedit-plugin work with python2

 devhelp-python2.patch | 27 +++++++++++++++++++++++++++
 devhelp.spec          |  8 +++++++-
 2 files changed, 34 insertions(+), 1 deletion(-)
 create mode 100644 devhelp-python2.patch
Comment 2 Matěj Cepl 2013-10-08 12:44:02 EDT
Created attachment 809415 [details]
rebased patch
Comment 4 Matthew Barnes 2013-10-14 11:16:14 EDT
Patch applied to devhelp-3.8.2-4.el7
Comment 7 Ludek Smid 2014-06-13 07:47:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.