Bug 97948 - indicate bash shell in installation documentation
indicate bash shell in installation documentation
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: documentation (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-24 10:16 EDT by Crag Wolfe
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 22:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Crag Wolfe 2003-06-24 10:16:58 EDT
The Environment Configuration under installation documentation should probably
mention to the user that they should be using the bash shell (ie, the scripts
will fail using tcsh).
Comment 1 Karsten Wade 2003-07-04 05:15:22 EDT
Is this only for RPM installation?  Or do other installation methods require bash?

Do we know what exactly requires bash?  Is that requirement a bug?

If the issue is just with the RPM installation, this is the location I believe
should have the NOTE:

http://www.redhat.com/docs/manuals/rhea/RHEA-5.2.1-Manual/rhea-ig-waf-en/ch-bin-install.html#S1-RPM-BIN-INSTALL

If the issue is larger, and the target system needs to be using bash regardless
of OS, then I would post the NOTE on/around this location:

http://www.redhat.com/docs/manuals/rhea/RHEA-5.2.1-Manual/rhea-ig-waf-en/ch-pre-install.html

Thanks!
Comment 2 Karsten Wade 2003-11-06 22:07:49 EST
The existence of /bin/sh and the usage of a Bourne shell compatible
continues to be a requirement of UNIX based installations.

This has been included in the Rickshaw WAF Install Guide as an
appropriate admonition.

Note You need to log in before you can comment on or make changes to this bug.