Bug 979510 - dhclient: unable to release lease / DHCPRELEASE
dhclient: unable to release lease / DHCPRELEASE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 13:09 EDT by alcantar4
Modified: 2013-07-22 21:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: dhcp-4.2.5-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 20:48:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alcantar4 2013-06-28 13:09:18 EDT
Description of problem:

Fedora 17 and 18 dhclients are unable to release a DHCP lease do to a previously introduced patch.

The patch introduced by bug id #800561 causes the dhclient to set the address of the layer 2 destination for DHCPRELEASE packets to the broadcast address (ff:ff:ff:ff:ff:ff).  The RedHat bug ID (800561) with the justification for this patch is outlined at the following URL: https://bugzilla.redhat.com/show_bug.cgi?id=800561


Version-Release number of selected component: dhclient-4.2.5-12.fc18.x86_64


How reproducible: Highly

Steps to Reproduce:
1. Acquire dhcp lease
2. Release lease:  dhclient –r

Actual results:

Request does not reach DHCP server and leases is not released


Expected results:

Request reaches DHCP server and leases is released


Additional info:

When building and testing with ISC source the problem is not exhibited.

Download the ISC source and build the dhclient using the following default method builds a dhclient that does not send DHCPRELEASE packets with the layer 2 broadcast destination.

Download and uncompress the *.tar.gz file

cd to the uncompressed directory

./configure && make

Furthermore, extracting the dhcp source rpm from Fedora and commenting out the patch that introduced the change to the layer 2 broadcast destination address results in a properly functioning dhclient.
Comment 1 Ben Greear 2013-06-28 18:00:35 EDT
I actually ended up re-writing the patch that causes this bug, but never tried to push it upstream.  (I find it a total pain to try to write patches for upstream
since I never found an active upstream tree under source control).

For what it's worth, we've been testing the re-write for 7 months or so
and it appears to work fine.  I'm sure we don't hit all possible corner
cases, however.

Any chance you could try this version and see if it works for you?

https://github.com/greearb/dhcp-ct
Comment 2 Fedora Update System 2013-07-02 08:25:04 EDT
dhcp-4.2.5-15.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dhcp-4.2.5-15.fc19
Comment 3 Fedora Update System 2013-07-02 08:25:32 EDT
dhcp-4.2.5-15.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dhcp-4.2.5-15.fc18
Comment 4 Fedora Update System 2013-07-02 21:36:49 EDT
Package dhcp-4.2.5-15.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.5-15.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12151/dhcp-4.2.5-15.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-05 20:48:47 EDT
dhcp-4.2.5-15.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-07-10 06:47:37 EDT
dhcp-4.2.5-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.5-3.fc17
Comment 7 Fedora Update System 2013-07-11 23:00:00 EDT
dhcp-4.2.5-15.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-07-22 21:13:48 EDT
dhcp-4.2.5-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.