Bug 979640 - SELinux is preventing /opt/google/chrome/chrome from 'open' accesses on the file /home/ivan/libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from 'open' accesses on the f...
Status: CLOSED DUPLICATE of bug 960792
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d1e61f6335d4a554c3ed77c0b6a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 21:16 EDT by ifernandez.aquino
Modified: 2013-06-29 06:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 06:27:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ifernandez.aquino 2013-06-28 21:16:15 EDT
Description of problem:
SELinux is preventing /opt/google/chrome/chrome from 'open' accesses on the file /home/ivan/libpeerconnection.log.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/home/ivan/libpeerconnection.log default label should be user_home_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /home/ivan/libpeerconnection.log

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that chrome should be allowed open access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/ivan/libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.52-207119.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.6-200.fc18.x86_64 #1 SMP Thu
                              Jun 13 18:56:55 UTC 2013 x86_64 x86_64
Alert Count                   6
First Seen                    2013-06-27 16:52:32 PET
Last Seen                     2013-06-28 20:06:57 PET
Local ID                      f41dbfac-2b77-4a8d-a283-c838eb21a593

Raw Audit Messages
type=AVC msg=audit(1372468017.318:380): avc:  denied  { open } for  pid=2672 comm="chrome" path="/home/ivan/libpeerconnection.log" dev="dm-2" ino=20717878 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1372468017.318:380): arch=x86_64 syscall=open success=no exit=EACCES a0=7fb3d7bab978 a1=441 a2=1b6 a3=ffffe000 items=0 ppid=0 pid=2672 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=2 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,open

audit2allow

#============= chrome_sandbox_t ==============
#!!!! This avc is allowed in the current policy

allow chrome_sandbox_t user_home_dir_t:file open;

audit2allow -R
require {
	type chrome_sandbox_t;
	type user_home_dir_t;
	class file open;
}

#============= chrome_sandbox_t ==============
#!!!! This avc is allowed in the current policy

allow chrome_sandbox_t user_home_dir_t:file open;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.6-200.fc18.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-06-29 06:27:40 EDT

*** This bug has been marked as a duplicate of bug 960792 ***

Note You need to log in before you can comment on or make changes to this bug.