Bug 979643 - F19 installation fails when using kickstart on netinst.iso
F19 installation fails when using kickstart on netinst.iso
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 22:06 EDT by Tomas Dabašinskas
Modified: 2014-02-21 13:44 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 13:44:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (2.49 KB, text/plain)
2013-06-28 22:07 EDT, Tomas Dabašinskas
no flags Details
storage log (27.82 KB, text/plain)
2013-06-28 22:07 EDT, Tomas Dabašinskas
no flags Details
packaging log (544.44 KB, text/plain)
2013-06-28 22:09 EDT, Tomas Dabašinskas
no flags Details
program log (8.91 KB, text/plain)
2013-06-28 22:10 EDT, Tomas Dabašinskas
no flags Details
repo error (13.44 KB, image/png)
2013-06-29 00:24 EDT, Tomas Dabašinskas
no flags Details

  None (edit)
Description Tomas Dabašinskas 2013-06-28 22:06:40 EDT
Hi,
I'm trying to install f19 using kickstart,
I'm booting from Fedora-19-Beta-x86_64-netinst.iso
I've added ks=http://people.fedoraproject.org/~tdabasin/ks/f19-min.ks to kernel line, kickstart is downloaded and installer detects automated install and starts using it, but it never finishes...

I belive install process breaks on LVM. I'm seeing error messages related to dm-event.socket service, when I check its status, I get:

Loaded: error reason no such file or directory
Comment 1 Tomas Dabašinskas 2013-06-28 22:07:20 EDT
Created attachment 766788 [details]
anaconda log
Comment 2 Tomas Dabašinskas 2013-06-28 22:07:55 EDT
Created attachment 766789 [details]
storage log
Comment 3 Tomas Dabašinskas 2013-06-28 22:09:31 EDT
Created attachment 766790 [details]
packaging log
Comment 4 Tomas Dabašinskas 2013-06-28 22:10:03 EDT
Created attachment 766791 [details]
program log
Comment 5 Tomas Dabašinskas 2013-06-28 22:51:19 EDT
I've also tried using ks=http://people.fedoraproject.org/~tdabasin/ks/f18-min.ks which works fine on Fedora-18-x86_64-netinst.iso it appears to be wroking on Fedora-19-Beta-x86_64-netinst.iso maybe not a bug, would be nice if somebody could verify please.
Comment 6 Adam Williamson 2013-06-29 00:14:51 EDT
When you say "kickstart is downloaded and installer detects automated install and starts using it, but it never finishes..." , what do you mean exactly? What do you see?

Can you try with https://dl.fedoraproject.org/pub/alt/stage/19-RC3/Fedora/x86_64/iso/Fedora-19-x86_64-netinst.iso instead of Beta?
Comment 7 Tomas Dabašinskas 2013-06-29 00:23:09 EDT
Adam, sorry about the confusion, I see the message: Starting automated install...
and from that I understand that kickstart is being used. 

I have tried clearning partitions manually and installing beta again, and it worked. I have also tried installing the same beta on top of existing fedora install and that worked too. I'm not able to reproduce the bug now (maybe it's my vm)

There's 1 warning during the install however (please see attached), but that doesn't seem to affect the installation. 

I'll download and try fedora 19 RC iso and try with that too, will post updates here.
Comment 8 Tomas Dabašinskas 2013-06-29 00:24:32 EDT
Created attachment 766794 [details]
repo error
Comment 9 Adam Williamson 2013-06-29 00:30:18 EDT
oh, yeah, we know about that one. the fact that it's displayed is a bug - it should be suppressed - but it doesn't mean that anything's wrong.

I've seen it sit at "Starting automated install..." with the number of "."s growing for quite a while on a few of my tests, don't know why it's so slow sometimes. So it's possible it was being slow and you were just impatient, I guess. If it's worked in subsequent tries, we're probably good.

It likely wasn't stuck on partitioning - I believe at that point it hasn't actually started partitioning yet. I'm not sure precisely what it's _doing_ when it's sat at the "Starting..." message, but partitioning definitely comes after.
Comment 10 Tomas Dabašinskas 2013-06-29 00:50:18 EDT
Fedora-19-x86_64-netinst.iso worked fine with no errors/warnings, in some instances the installation on top of another fedora would hang, after clearing all partitions with fdisk, install works fine. I wouldn't be surprised if this is something to do with my vm...
Comment 11 Craig J Perry 2013-11-14 11:09:49 EST
I've stumbled into this bug. It's consistently repeatable (so far) by booting the netinst CD with a kickstart file param. The DVD used in the same way doesn't exhibit the same behaviour.

The only clues are in the storage log screen, it appears to be probing existing (old) md devices on the disks. They're not visible in /proc/mdstat in the installer environment though so it doesn't appear to assemble the MD arrays.

I used Tomas's workaround (wipe the disks) and on reboot with no other changes, i got a successful install.

There are 2 workarounds i know of: use the DVD, clear the disks manually beforehand. So i don't propose re-opening this. However it is first hit in duckduckgo and google for this problem, so hopefully useful to others.
Comment 12 David Shea 2014-02-21 13:44:29 EST
comment 11 sounds like a separate issue with storage configuration. If you believe it is a bug in anaconda, open a new bug and attach the log files from /tmp as individual, text/plain attachments.

Note You need to log in before you can comment on or make changes to this bug.