Bug 979655 - F19 fix updates repo for kickstart installation on netinst.iso
F19 fix updates repo for kickstart installation on netinst.iso
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 02:24 EDT by Tomas Dabašinskas
Modified: 2013-06-29 04:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 04:03:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dabašinskas 2013-06-29 02:24:59 EDT
I'm trying to enable updates repo in my kickstart file using:

repo --name="updates"

When I run the install process I'm getting following errors:

/tmp/packaging.log:05:54:45,354 ERR packaging: failed to get groups for repo updates
/tmp/packaging.log:05:55:58,196 ERR packaging: failed to get groups for repo updates
/tmp/program.log:05:54:05,680 ERR program: Error running arch: No such file or directory

I tried adding --ignoregroups=true, but the error about the groups still comes up (not sure what is the impact of that error).

"arch" from product log I believe refers to arch variable used in /etc/anaconda.repos.d/fedora-updates.repo 

Would hardcoding the arch and release numbers in /etc/anaconda.repos.d fix the problem and is it a good solution?

I know updates not really useful at the moment, but in few months it will be very nice to install the system with the updates. I have no way of verifying this (whether updates repo was used or not), yum update right after the install doesn't find any updates.

http://fedoraproject.org/wiki/Anaconda/Kickstart#repo
Comment 1 Tomas Dabašinskas 2013-06-29 04:03:01 EDT
I have just tried adding custom repo: 

repo --name="fed-updates"  --mirrorlist="https://mirrors.fedoraproject.org/metal
ink?repo=updates-released-f19&arch=x86_64"

I still get the same errors which leads me to believe there's no problem with parsing variables from fedora-updates.repo file, and updates repo is enabled...

I have also tried adding:
repo --name="fed-updates-testing"  --mirrorlist="https://mirrors.fedoraproject.org/metal
ink?repo=updates-testing-f19&arch=x86_64"

After installation I logged in as root and tried running:
yum update --enablerepo=updates-testing and there were no packages listed for update, which means the repo is working. Closing not a bug

Note You need to log in before you can comment on or make changes to this bug.