Bug 979690 - python-tevent has invalid Requires:
python-tevent has invalid Requires:
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libtevent (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 08:09 EDT by David Woodhouse
Modified: 2013-07-01 08:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 08:27:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2013-06-29 08:09:08 EDT
If I try to install python-tevent on an x86_64 machine, it tries to pull in the 32-bit libtevent:

# yum install python-tevent
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package python-tevent.x86_64 0:0.9.18-1.fc19 will be installed
--> Processing Dependency: libtevent = 0.9.18-1.fc19 for package: python-tevent-0.9.18-1.fc19.x86_64
--> Running transaction check
---> Package libtevent.i686 0:0.9.18-1.fc19 will be installed
--> Processing Dependency: libtalloc.so.2(TALLOC_2.0.2) for package: libtevent-0.9.18-1.fc19.i686
--> Processing Dependency: libtalloc.so.2 for package: libtevent-0.9.18-1.fc19.i686
--> Processing Dependency: libdl.so.2 for package: libtevent-0.9.18-1.fc19.i686
--> Processing Dependency: libcrypt.so.1 for package: libtevent-0.9.18-1.fc19.i686
--> Processing Dependency: libc.so.6(GLIBC_2.15) for package: libtevent-0.9.18-1.fc19.i686
--> Running transaction check
---> Package glibc.i686 0:2.17-4.fc19 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-4.fc19.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-4.fc19.i686
---> Package libtalloc.i686 0:2.0.8-2.fc19 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-1.fc19 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libtevent which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libtevent of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libtevent.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libtevent installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libtevent installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libtevent-0.9.18-1.fc19.i686 != libtevent-0.9.18-2.fc19.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.14.3-1.fc19.i686 != nss-softokn-freebl-3.15-3.fc19.x86_64
Comment 1 Jakub Hrozek 2013-06-30 15:15:43 EDT
I think the problem was that either repo was out of sync or the nss update went from testing to stable sooner than tevent update did. Does the problem still persist? Does it go away if you toggle the state of updates-testing on your machine?

The tevent packaging has not changed in ages and we've never seen this problem.

Anyway, I'll be afk next week, so I won't reply to the bug report, but if my suspiction is correct, then I'm sure either Simo or Andreas would close this report.
Comment 2 David Woodhouse 2013-07-01 02:27:09 EDT
$ rpm -qp --requires  python-tevent-0.9.18-1.fc19.x86_64.rpm  | grep ^libtevent\ 
warning: python-tevent-0.9.18-1.fc19.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fb4b18e6: NOKEY
libtevent = 0.9.18-1.fc19


I believe that should have a %{?_isa} somewhere...
Comment 3 David Woodhouse 2013-07-01 03:36:10 EDT
You're quite right, of course, that there's a repository out of sync. But with the following fixed Requires, the output from yum is a whole lot clearer about that, because it doesn't go off into the weeds trying to install a completely wrong package.

-Requires: libtevent = %{version}-%{release}
+Requires: libtevent%{?_isa} = %{version}-%{release}

Error: Package: python-tevent-0.9.18-1.fc19.x86_64 (/python-tevent-0.9.18-1.fc19.x86_64)
           Requires: libtevent(x86-64) = 0.9.18-1.fc19
           Installed: libtevent-0.9.18-2.fc19.x86_64 (@updates-testing)
               libtevent(x86-64) = 0.9.18-2.fc19
           Available: libtevent-0.9.18-1.fc19.x86_64 (fedora)
               libtevent(x86-64) = 0.9.18-1.fc19
 You could try using --skip-broken to work around the problem

You can see it's correctly failing to find the libtevent(x86_64) package that it wants, telling me so, and bailing out — rather than trying to install an i686 version instead and rapidly going downhill from there.
Comment 4 Stephen Gallagher 2013-07-01 08:27:13 EDT
I've fixed this in the Rawhide branch. I'll leave it up to Jakub and Simo to decide if it's important enough to backport to F19/F18.

Note You need to log in before you can comment on or make changes to this bug.