This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979692 - doesn't activate lv's on boot
doesn't activate lv's on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 08:22 EDT by udo
Modified: 2013-07-08 10:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 09:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport. (61.18 KB, application/x-gzip)
2013-07-08 09:30 EDT, udo
no flags Details

  None (edit)
Description udo 2013-06-29 08:22:51 EDT
Description of problem:
When booting my kernel.org (3.9.8 or so) only the root-lv is activated.
it appears that vgchange -ay is not executed


Version-Release number of selected component (if applicable):
Fedora current

How reproducible:
Boot
See dracut shell happen
do `lvm vgchange -ay`
`exit`
and see boot continue
(but is stuck on encrypted swap partition job...)


Expected results:
No lvm issue

Additional info:
Comment 1 udo 2013-07-06 01:03:56 EDT
What info do you need to fix this bug?
Comment 2 Harald Hoyer 2013-07-08 04:59:49 EDT
(In reply to udo from comment #1)
> What info do you need to fix this bug?

Boot with "rd.debug" on the kernel command line.

Do your lvm vgchange -ay, boot.

# journalctl -ab --no-pager -o short-monotonic > /tmp/sosreport.txt

and attach /tmp/sosreport.txt
Comment 3 udo 2013-07-08 09:30:50 EDT
Created attachment 770479 [details]
sosreport.
Comment 4 Harald Hoyer 2013-07-08 09:57:09 EDT
your kernel command line is missing "rd.lvm.vg=my_vg" or "rd.lvm.lv=my_vg/usrlv" , because you seem to have a split /usr-

Please add "rd.lvm.vg=my_vg" to your kernel command line.
Comment 5 udo 2013-07-08 10:07:39 EDT
Thanks for your quick reply.
rd.lvm.vg=my_vg did indeed help!
Where is this documented for me and others to read as change for Fedora 18?
Please give us a link so we can be informed.

THANKS!
Comment 6 Harald Hoyer 2013-07-08 10:49:19 EDT
https://fedoraproject.org/wiki/Upgrading_from_EOL_Fedora_using_yum#Fedora_16_-.3E_Fedora_17

...
If you have /usr on LVM, MD raid or DM raid, make sure the kernel command line has either all settings like "rd.lvm.lv=..." to ensure the /usr device is accessible in dracut or just remove all restrictions like "rd.lvm...", "rd.md...", "rd.dm...". Either way, you should probably use anaconda to update, if you are experiencing problems with a separate /usr. 
...

The problem here is, that you had root=/dev/mapper/... which turned into "rd.lvm.lv=", but without the /usr LV.
Comment 7 Harald Hoyer 2013-07-08 10:51:23 EDT
In Fedora 19, this will be solved with the host-only initramfs, because dracut does parses your /etc/fstab and knows what to activate and wait for.
Comment 8 udo 2013-07-08 10:54:37 EDT
Thanks for explaining!

For a perhaps related issue: https://bugzilla.redhat.com/show_bug.cgi?id=979695 does that also require extra kernel commandline parameters in Fedora 18?

Note You need to log in before you can comment on or make changes to this bug.