Bug 979710 - KDE SystemTray plasmoid shows a different set of system tray icons on different monitors
KDE SystemTray plasmoid shows a different set of system tray icons on differe...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 15:02 EDT by Alexei Panov
Modified: 2013-06-30 21:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-30 21:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with problem (2.94 MB, image/png)
2013-06-29 15:02 EDT, Alexei Panov
no flags Details

  None (edit)
Description Alexei Panov 2013-06-29 15:02:43 EDT
Created attachment 766935 [details]
Screenshot with problem

Description of problem:
KDE SystemTray plasmoid shows a different set of system tray icons on different monitors. I have 2 panels on each monitor. And I have SystemTray plasmoid on each panel. gajim, Qtransmission and other tray icons show only in right SystemTray plasmoid.

Version-Release number of selected component (if applicable):
4.10.4-5.fc19 (I have checked kde-workspace-4.10.4-6.fc19 too).

How reproducible:
All time

Steps to Reproduce:
1. Run KDE on a system with 2 monitors
2. add 2 panels with SystemTray plasmoid on each panel
3. run applications with the tray icon

Actual results:
tray icons only appear in only one plasmoid

Expected results:
Icons appear on all plasmoids SystemTray

Additional info:
Green shows the allocation of plasmoid without icons (left).
Red indicates the allocation of a plasmoid with application icons (right).
Comment 1 Kevin Kofler 2013-06-30 21:13:00 EDT
This is a technical limitation of the old XEmbed-based system tray protocol which all the non-KDE applications still use: The system tray icon can only be embedded at one place, so it can only show up in one of the 2 system trays you have. As long as the applications use the old protocol (which is going to be a while, because neither upstream Qt 4 nor upstream GTK+ support the new protocol), this cannot be fixed.

Note You need to log in before you can comment on or make changes to this bug.