Bug 979717 - missing nsd policy, despites being in refpolicy
missing nsd policy, despites being in refpolicy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 16:02 EDT by Michael Scherer
Modified: 2013-07-06 21:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-59.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-06 21:33:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add the module to the rpm (1.05 KB, patch)
2013-06-29 17:05 EDT, Michael Scherer
no flags Details | Diff

  None (edit)
Description Michael Scherer 2013-06-29 16:02:14 EDT
It seems there is a nsd policy in serefpolicy :

fedpkg/selinux-policy/serefpolicy-3.10.0 $ find . | grep nsd.te
./policy/modules/services/nsd.te

Yet, it is not compiled and cannot be found anywhere. 

Since we do provides nsd, it make sense to have the policy. The module is in the tarball since 2006, according to git log.
Comment 1 Michael Scherer 2013-06-29 17:05:03 EDT
Created attachment 766944 [details]
Add the module to the rpm

Add the module to the rpm. I didn't however test, so I guess it should be placed as permissive.
Comment 2 Miroslav Grepl 2013-07-01 07:31:57 EDT
I will activate it in Rawhide and make as permissive in F19.
Comment 3 Fedora Update System 2013-07-03 15:50:46 EDT
selinux-policy-3.12.1-59.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-59.fc19
Comment 4 Fedora Update System 2013-07-04 22:14:30 EDT
Package selinux-policy-3.12.1-59.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-59.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12373/selinux-policy-3.12.1-59.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-06 21:33:44 EDT
selinux-policy-3.12.1-59.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.