Bug 979719 - mod_nss documentation & config file should mention TLS 1.1
mod_nss documentation & config file should mention TLS 1.1
Status: CLOSED DUPLICATE of bug 816394
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mod_nss (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Matthew Harmsen
Kaleem
:
Depends On: 816394 979799
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 16:20 EDT by David Jaša
Modified: 2013-10-29 14:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 979718
Environment:
Last Closed: 2013-10-29 14:07:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-06-29 16:20:56 EDT
Applies to RHEL 6 as well:
mod_nss-1.0.8-18.el6.x86_64
nss-3.14.0.0-12.el6.x86_64

+++ This bug was initially created as a clone of Bug #979718 +++

Description of problem:
nss supports TLS 1.1 since 3.14 version and mod_nss picks it up correctly if admin specifies "NSSProtocol TLSv1.1" directive in nss.conf.

Neither documenation, nor comments in nss.conf do mention this fact though so admins may end up with false conclusion that TLS > 1.0 are not supported...

Version-Release number of selected component (if applicable):
mod_nss-1.0.8-20.1.fc19.armv7hl
nss-3.14.3-13.0.fc19.armv7hl

How reproducible:
always

Steps to Reproduce:
1. look at /usr/share/doc/mod_nss-1.0.8/mod_nss.html and /etc/httpd/conf.d/nss.conf for TLSv1.1
2.
3.

Actual results:
TLS 1.1 support is not advertised at all

Expected results:
* TLS 1.1 should be mentioned at both places
* TLSv1.1 should be default value for NSSProtocol directive (this may need further discussion because of client compatibility issue potential)

Additional info:
documentation could be probably generated so it picks up current values supported by nss
Comment 1 Matthew Harmsen 2013-10-29 14:07:44 EDT
(In reply to David Jaša from comment #0)
> Applies to RHEL 6 as well:
> mod_nss-1.0.8-18.el6.x86_64
> nss-3.14.0.0-12.el6.x86_64
> 
> +++ This bug was initially created as a clone of Bug #979718 +++
> 
> Description of problem:
> nss supports TLS 1.1 since 3.14 version and mod_nss picks it up correctly if
> admin specifies "NSSProtocol TLSv1.1" directive in nss.conf.
> 
> Neither documenation, nor comments in nss.conf do mention this fact though
> so admins may end up with false conclusion that TLS > 1.0 are not
> supported...
> 
> Version-Release number of selected component (if applicable):
> mod_nss-1.0.8-20.1.fc19.armv7hl
> nss-3.14.3-13.0.fc19.armv7hl
> 

Support for TLS v1.1 in RHEL 6 has been provided since mod_nss-1.0.8-17.el6, so I am marking this bug as a DUPLICATE of 'Bugzilla Bug #816394 - [RFE] Provide Apache 2.2 support for TLS v1.1 via NSS through mod_nss . . .'.

The patch which supported this has now been ported upstream and is available in the following Brew builds which are awaiting karma in Bodhi:

* mod_nss-1.0.8-24.fc18
* mod_nss-1.0.8-24.fc19
* mod_nss-1.0.8-24.fc20

Please feel free to provide karma for these builds.

Finally, I noticed that since the packages referenced must be customized builds for the 'armv7hl' architecture, please try using the appropriate Fedora SRPM to reproduce your packages.

> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. look at /usr/share/doc/mod_nss-1.0.8/mod_nss.html and
> /etc/httpd/conf.d/nss.conf for TLSv1.1
> 2.
> 3.
> 
> Actual results:
> TLS 1.1 support is not advertised at all
> 
> Expected results:
> * TLS 1.1 should be mentioned at both places
> * TLSv1.1 should be default value for NSSProtocol directive (this may need
> further discussion because of client compatibility issue potential)
> 
> Additional info:
> documentation could be probably generated so it picks up current values
> supported by nss

*** This bug has been marked as a duplicate of bug 816394 ***

Note You need to log in before you can comment on or make changes to this bug.