Bug 979805 - insufficient post-MBR gap not detected before installation
insufficient post-MBR gap not detected before installation
Status: CLOSED DUPLICATE of bug 986431
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 14:34 EDT by Germano Massullo
Modified: 2013-09-03 11:39 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 11:39:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (1.28 MB, text/plain)
2013-06-30 14:34 EDT, Germano Massullo
no flags Details

  None (edit)
Description Germano Massullo 2013-06-30 14:34:08 EDT
Created attachment 915728 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Germano Massullo 2013-07-02 10:21:50 EDT
I think it is related to
https://bugzilla.redhat.com/show_bug.cgi?id=861192
Comment 2 Chris Murphy 2013-07-02 11:05:17 EDT
The crash is a bug, but the cause for the crash isn't something the installer can do anything about:

22:26:16,390 INFO program: Running... grub2-install --no-floppy /dev/sda
22:26:18,184 ERR program: /usr/sbin/grub2-bios-setup: warning: your embedding area is unusually small.  core.img won't fit in it..

Means grub can't find enough space to install core.img. And then this entry for /dev/sda1 is why:

 'ID_PART_ENTRY_OFFSET': '28',

There's only 27 512 byte sectors from the start of the disk to the start of the first partition (which is NTFS) and that's simply not enough space. So the disk isn't partitioned correctly. For some years, the first partition should start at LBA 2048 for both Microsoft and Linux partition tools, so I'm not sure what started this first partition at LBA 28, but that's the problem.

A possible solution would be to move/resize the NTFS volume so that it starts at LBA 2048, using gparted. Then boot from the Fedora install media and re-run grub2-install /dev/sda. Or reinstall.
Comment 3 Germano Massullo 2013-07-02 11:53:05 EDT
(In reply to Chris Murphy from comment #2)
> The crash is a bug, but the cause for the crash isn't something the
> installer can do anything about:

I think that the user should be warned of thenot enough space problem before the installations starts.

> A possible solution would be to move/resize the NTFS volume so that it
> starts at LBA 2048, using gparted. Then boot from the Fedora install media
> and re-run grub2-install /dev/sda. Or reinstall.
Yes I am doing this right now.
Comment 4 Steve Tyler 2013-07-04 13:30:37 EDT
(In reply to Germano Massullo from comment #3)
> (In reply to Chris Murphy from comment #2)
> > The crash is a bug, but the cause for the crash isn't something the
> > installer can do anything about:
> 
> I think that the user should be warned of thenot enough space problem before
> the installations starts.

Thanks for your report. I completely agree. The bug summary could be changed to:

"insufficient post-MBR gap not detected before installation"

> > A possible solution would be to move/resize the NTFS volume so that it
> > starts at LBA 2048, using gparted. Then boot from the Fedora install media
> > and re-run grub2-install /dev/sda. Or reinstall.
> Yes I am doing this right now.

For the record, how did you partition your disk to get the 28 sector offset to the NTFS partition (sda1)? (Compare Bug 969709 Comment 18).

BTW, you can attach log files by clicking the "Add an attachment" link at the top of the bug report.
Comment 5 Germano Massullo 2013-07-04 13:44:08 EDT
(In reply to Steve Tyler from comment #4)
> For the record, how did you partition your disk to get the 28 sector offset
> to the NTFS partition (sda1)? (Compare Bug 969709 Comment 18).
I do not know, it is a Thinkpad bought from nbwn.de, they shipped it with that kind of partitions
Comment 6 Steve Tyler 2013-07-04 14:56:59 EDT
(In reply to Germano Massullo from comment #5)
> (In reply to Steve Tyler from comment #4)
> > For the record, how did you partition your disk to get the 28 sector offset
> > to the NTFS partition (sda1)? (Compare Bug 969709 Comment 18).
> I do not know, it is a Thinkpad bought from nbwn.de, they shipped it with
> that kind of partitions

Thanks Germano, that's very interesting ...

nbwn.de appears to be selling used notebooks ("Notebooks wie neu").
(In English, used notebooks would probably called "refurbished".)

Could you confirm that?

Is so, they may not be correctly reinstalling Windows.

Chris, what do you think?
Comment 7 Chris Murphy 2013-07-04 15:48:53 EDT
A copy of Windows 7 Ultimate, when targeted at a blank disk (no partition table) will create two NTFS partitions, the first one starting at LBA 2048 and is ~100MB in size.

The disk in this bug description, however, starts at LBA 28 and is ~1.5GB in size, with three total existing NTFS volumes.

, existing 1500MB partition sda1 (3) with existing ntfs filesystem
, existing 459055MB partition sda2 (4) with existing ntfs filesystem
, existing 16381MB partition sda3 (5) with existing ntfs filesystem

Maybe an OEM Windows restore disk has done this? I really don't know how common it is to have MBR schemed disks with less than 63 sectors of space.
Comment 8 Germano Massullo 2013-07-04 16:19:59 EDT
(In reply to Steve Tyler from comment #6)
> Thanks Germano, that's very interesting ...
> 
> nbwn.de appears to be selling used notebooks ("Notebooks wie neu").
> (In English, used notebooks would probably called "refurbished".)
> 
> Could you confirm that?
Yes, they sell refurbished notebooks
Comment 9 Steve Tyler 2013-07-04 23:45:44 EDT
Thanks Chris and Germano.

The best thing to do might be to contact NBWN and let them know that their disk partitioning is incompatible with Fedora:
http://www.nbwn.com/content/7/contact.html

They say they refurbish Lenovo demo units here:
http://www.nbwn.com/content/11/what-is-the-demopool.html
Comment 10 Germano Massullo 2013-07-05 05:30:37 EDT
(In reply to Steve Tyler from comment #9)
> The best thing to do might be to contact NBWN and let them know that their
> disk partitioning is incompatible with Fedora:
> http://www.nbwn.com/content/7/contact.html
I have tought about, but I don't know about particular things of partitions, then I did not wrote to them.
Comment 11 Steve Tyler 2013-07-20 14:24:59 EDT
See also:
Bug 986431 - Anaconda fails to install bootloader if legacy MBR has only 36 sectors before 1st partition
Comment 12 Steve Tyler 2013-08-22 15:14:21 EDT
This bug appears to be a duplicate:
Bug 986431 - Anaconda fails to install bootloader if legacy MBR has only 36 sectors before 1st partition
Comment 13 David Shea 2013-09-03 11:39:40 EDT

*** This bug has been marked as a duplicate of bug 986431 ***

Note You need to log in before you can comment on or make changes to this bug.