Bug 979837 - RFE: Descriptive titles for revision history topics
RFE: Descriptive titles for revision history topics
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks: 991239
  Show dependency treegraph
 
Reported: 2013-06-30 21:33 EDT by Misha H. Ali
Modified: 2013-08-01 19:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 991239 (view as bug list)
Environment:
Last Closed: 2013-08-01 19:49:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testing results (32.20 KB, image/png)
2013-08-01 19:45 EDT, Misha H. Ali
no flags Details

  None (edit)
Description Misha H. Ali 2013-06-30 21:33:43 EDT
Currently the Revision History topic type works as all topics do: the title appears as the title for the topic in the document.

However, it would probably be more useful if we could set topic titles for revision history topics according to the product, version, docname and whether it is GA, Beta, Alpha, etc.

Currently, if I search for all topics I have created that are of the Revision History type, the results would be a list of topics named simply Revision History. it is unnecessarily hard to find the one I am looking for.

Instead, if the results were as follows, it is much easier to pick out the one I need:

JDG 6.0 Beta Admin Guide Revision History
JDG 6.0 GA Admin Guide Revision History
JDG 6.0.1 GA Getting Started Guide Revision History
JDG 6.1 Beta Developer Guide Revision History

Additionally, the title for a revision history topic would always need to render as "Revision History" so perhaps that could be the default title while the title itself serves a more useful purpose as metadata.
Comment 1 Lee Newson 2013-08-01 04:52:24 EDT
I'm not sure when this actually went live (I suspect it was build 201307010911) but anyways you can currently do this via the UI by setting the Topic Title property as whatever you want and leaving the title in the XML as "Revision History". This is because the Revision History title isn't synced to the Revision History XML by the server (as it does for normal topics like misha mentioned).

As such I'm moving this RFE to the csprocessor, so that new Revision Histories can be created with a descriptive title.
Comment 2 Misha H. Ali 2013-08-01 19:25:45 EDT
Thanks, Lee. Testing now.
Comment 3 Lee Newson 2013-08-01 19:31:23 EDT
csprocessor fix cloned to BZ#991239
Comment 4 Misha H. Ali 2013-08-01 19:45:52 EDT
Created attachment 781786 [details]
Testing results

Tested bug with a subset of Revision History topics. Title is still Revision History while search results display the more descriptive titles set in the properties tab.
Comment 5 Lee Newson 2013-08-01 19:49:01 EDT
Thanks Misha :)

Note You need to log in before you can comment on or make changes to this bug.