Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 979881 - non-standard apostrophe in contentspec file and topic title causes csprocessor error
Summary: non-standard apostrophe in contentspec file and topic title causes csprocesso...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: PressGang CCMS
Classification: Community
Component: CSProcessor
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: pressgang-ccms-dev
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-01 05:33 UTC by Julie
Modified: 2013-07-01 05:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-01 05:55:23 UTC


Attachments (Terms of Use)

Description Julie 2013-07-01 05:33:12 UTC
Description of problem:
If the apostrophes in the content spec file and topic title didn't match, csprocessor returns an error when validating. I think it used to work without an error. 

Actual results:
[asettle@dhcp-1-185 Insight]$ csprocessor push
CSProcessor client version: 0.33.1
Loading configuration from /home/asettle/.config/csprocessor.ini
Loading project configuration from csprocessor.cfg
Connecting to PressGang server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Starting to parse...
Starting first validation pass...
Attempting to download all the latest topics...
Starting second validation pass...
ERROR: Line 503: Invalid Topic! Existing topic title doesn't match.
       -> Specified: To download a Timeline’s data
       -> Topic 15485: To download a Timeline's data
ERROR: The Content Specification is not valid.

Expected results:
csprocessor to function as normal

Comment 1 Lee Newson 2013-07-01 05:55:23 UTC
This is expected behaviour as the titles technically don't match. If you know all the title mismatches are just due to a topic title rename and not from using the wrong topic then you can add the "--permissive" (or "-p" for short) option to fix the titles up when the Content Spec is saved.


Note You need to log in before you can comment on or make changes to this bug.