Bug 979894 - python-django-south has even more invalid dependencies
python-django-south has even more invalid dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-django-south (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Luis Bazan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 02:00 EDT by Alex Chernyakhovsky
Modified: 2013-08-14 22:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-django-south-0.8.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 22:35:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Chernyakhovsky 2013-07-01 02:00:08 EDT
Description of problem:
In fixing Bug #976066, a build of python-django-south with a dependency on python-django14 was uploaded to Fedora 19. This conflicts with the installed python-django, and breaks the ability to use the new Django 1.5 on F19 with South.

Version-Release number of selected component (if applicable):
python-django-south-0.7.5-6.fc19.noarch

How reproducible:
Every time

Steps to Reproduce:
1. yum install python-django
2. yum install python-django-south
3.

Actual results:
[root@cats-whiskers ~]# yum update python-django-south
Loaded plugins: auto-update-debuginfo, langpacks, post-transaction-actions, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package python-django-south.noarch 0:0.7.5-5.fc19 will be updated
---> Package python-django-south.noarch 0:0.7.5-6.fc19 will be an update
--> Processing Dependency: python-django14 for package: python-django-south-0.7.5-6.fc19.noarch
--> Running transaction check
---> Package python-django14.noarch 0:1.4.5-7.fc19 will be installed
--> Processing Conflict: python-django14-1.4.5-7.fc19.noarch conflicts python-django >= 1.5
--> Finished Dependency Resolution
Error: python-django14 conflicts with python-django-1.5.1-1.fc19.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
python-django-south update is installed successfully.

Additional info:
Comment 1 Aurelien Bompard 2013-07-23 01:51:34 EDT
I'm hit by this but too. Apparently the dependency on django14 was added because of bug #950558 but it is not applicable, South is perfectly compatible with Django 1.5.

Please change the dependency back to python-django, this is currently blocking me from deploying a Django app.
Comment 2 Fedora Update System 2013-08-02 20:07:03 EDT
python-django-south-0.8.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-django-south-0.8.1-1.fc19
Comment 3 Fedora Update System 2013-08-03 20:11:11 EDT
Package python-django-south-0.8.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-django-south-0.8.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14203/python-django-south-0.8.1-1.fc19
then log in and leave karma (feedback).
Comment 4 John Schmitt 2013-08-03 20:34:13 EDT
I love it when I hit a bug and much progress has already been made.
Comment 5 John Schmitt 2013-08-03 20:42:39 EDT
Am I doing something wrong?  I want to use django 1.5 and south.

# yum --enablerepo=updates-testing install python-django-south
Loaded plugins: changelog, fastestmirror, keys, langpacks, local, merge-conf, show-leaves, upgrade-helper, verify

[...]

Resolving Dependencies
--> Running transaction check
---> Package python-django-south.noarch 0:0.7.5-6.fc19 will be installed
--> Processing Dependency: python-django14 for package: python-django-south-0.7.5-6.fc19.noarch
--> Running transaction check
---> Package python-django14.noarch 0:1.4.5-7.fc19 will be installed
--> Processing Conflict: python-django14-1.4.5-7.fc19.noarch conflicts python-django >= 1.5
--> Finished Dependency Resolution
Error: python-django14 conflicts with python-django-1.5.1-1.fc19.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 6 Alex Chernyakhovsky 2013-08-03 23:41:10 EDT
John, it looks like your nearest mirror hasn't gotten the new python-django-south, the version your yum is fetching is 0.7.5-6.fc19 but the update is 0.8.1-1.fc19.
Comment 7 John Schmitt 2013-08-05 16:55:39 EDT
Yes, thank you, Alex.  Ship it!
Comment 8 Luis Bazan 2013-08-05 17:03:46 EDT
Dear Friends!

Could give karma for the update if it is working properly.

Regards!
Comment 9 Fedora Update System 2013-08-14 22:35:09 EDT
python-django-south-0.8.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.