Bug 979942 - [abrt] cli.py:1015:_configure_repos:KeyError: <repo id>
[abrt] cli.py:1015:_configure_repos:KeyError: <repo id>
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
abrt_hash:5e7e8c888a024404f86bd4ebdca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 04:01 EDT by Zoltan Hoppar
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: dnf-0.3.9-1.giteff4c49.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 02:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.40 KB, text/plain)
2013-07-01 04:01 EDT, Zoltan Hoppar
no flags Details
File: core_backtrace (604 bytes, text/plain)
2013-07-01 04:01 EDT, Zoltan Hoppar
no flags Details

  None (edit)
Description Zoltan Hoppar 2013-07-01 04:01:49 EDT
Version-Release number of selected component:
dnf-0.3.8-2.git85524ae.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/dnf upgrade
executable:     /usr/bin/dnf
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
cli.py:1015:_configure_repos:KeyError: 'intellinuxgraphics'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 277, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 42, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 89, in _main
    cli.configure(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1243, in configure
    self._configure_repos(opts)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1015, in _configure_repos
    self.base.repos[rid].md_expire_cache()
KeyError: 'intellinuxgraphics'

Local variables in innermost frame:
rid: 'intellinuxgraphics'
self: <dnf.cli.cli.Cli object at 0x1dfe7d0>
opts: <Values at 0x1e0a050: {'verbose': None, 'errorlevel': None, 'color': None, 'disableexcludes': [], 'assumeno': None, 'debugsolver': None, 'conffile': None, 'exclude': [], 'rpmverbosity': None, 'enableplugins': [], 'best': None, 'disableplugins': [], 'sleeptime': None, 'version': None, 'releasever': None, 'obsoletes': None, 'debuglevel': None, 'cacheonly': None, 'showdupesfromrepos': None, 'assumeyes': None, 'debugrepodata': None, 'installroot': None, 'quiet': None, 'nogpgcheck': None, 'repos_ed': [], 'setopts': [], 'noplugins': None}>
Comment 1 Zoltan Hoppar 2013-07-01 04:01:54 EDT
Created attachment 767277 [details]
File: backtrace
Comment 2 Zoltan Hoppar 2013-07-01 04:01:58 EDT
Created attachment 767278 [details]
File: core_backtrace
Comment 3 Ales Kozumplik 2013-07-01 04:33:42 EDT
Reproducible by 'dnf clean expire-cache', removing or renaming one of the default-enabled repos and then 'dnf upgrade'.
Comment 4 Ales Kozumplik 2013-07-01 04:52:40 EDT
fixed by e0c11a6, will be included in dnf-0.3.9. Thanks for the report.
Comment 5 Fedora Update System 2013-07-08 04:14:51 EDT
dnf-0.3.9-1.giteff4c49.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.9-1.giteff4c49.fc19
Comment 6 Fedora Update System 2013-07-08 21:28:16 EDT
Package dnf-0.3.9-1.giteff4c49.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.3.9-1.giteff4c49.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12578/dnf-0.3.9-1.giteff4c49.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-18 02:08:41 EDT
dnf-0.3.9-1.giteff4c49.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.